Remove warning messages.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / xbmc / xbmc_git.bbappend
index 59039ed..cda2634 100644 (file)
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff"
 
 DEPENDS = "libgles libxslt libusb1 libcec libplist expat yajl gperf-native fribidi mpeg2dec samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0  bzip2 virtual/libsdl jasper zip-native zlib libtinyxml taglib libbluray libshairport librtmp zlib libnfs libxslt"
 
-RDEPENDS = "python"
-RDEPENDS += "\
+RDEPENDS_${PN} = "python"
+RDEPENDS_${PN} += "\
        python-distutils \
        python-subprocess \
        python-robotparser \
@@ -35,8 +35,8 @@ RDEPENDS += "\
        python-numbers \
        nfs-utils-client \
        libshairport \
-       eglibc-gconv-utf-32 \
-       lzma \
+       glibc-gconv-utf-32 \
+       xz \
        tiff \
        yajl \
        libxslt \
@@ -47,7 +47,7 @@ RDEPENDS += "\
        libnfs \
 "
 
-BUILD_PR="r2"
+BUILD_PR="r3"
 NATIVEGLES_PR="20141202_p0"
 
 BRANCH = "gotham_vuplus"
@@ -62,21 +62,18 @@ SRC_URI = "git://code.vuplus.com/git/xbmc.git;protocol=http;branch=${BRANCH};tag
 S = "${WORKDIR}/git"
 
 EXTRA_OECONF = " \
-       --disable-rpath \
        --enable-gles \
        --enable-libusb \
        --enable-airplay \
        --disable-optical-drive \
        --enable-external-libraries \
        --disable-ssh \
-       --enable-external_ffmpeg \
        --disable-x11 \
        --disable-sdl \
        --disable-joystick \
        --disable-alsa \
        --disable-libcec \
        --enable-rtmp   \
-       --disable-gnutls \
        --disable-texturepacker \
        --with-platform=dvbbox \
 "
@@ -100,3 +97,5 @@ FILES_${PN} += "/usr/bin /usr/share /usr/lib"
 SRC_URI[xbmc-support.md5sum] = "9d0c73505484823e3816b5577f28a8a8"
 SRC_URI[xbmc-support.sha256sum] = "5483e24db81efca03120dbf0ef4cc423d2665ebc4d52149be15d75a0ae9b626d"
 
+INSANE_SKIP_${PN} = "already-stripped"
+