[initscripts] fix turnoff_power on arm(solo4k).
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-core / initscripts / initscripts_1.0.bbappend
index 9474af7..3033eb7 100644 (file)
@@ -1,13 +1,16 @@
-PR .= "-vuplus11"
+PR .= "-vuplus14"
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
 
 SRC_URI_append = " \
        file://turnoff_power \
-       file://hotplug_br \
        file://make_mac_sector \
 "
 
+SRC_URI_append_mipsel = " \
+       file://hotplug_br \
+"
+
 do_configure_prepend() {
         sed -i 's/tty0/ttyS0/' ${WORKDIR}/banner.sh
 }
@@ -17,7 +20,6 @@ do_install_append() {
 
        install -d ${D}/usr/bin 
        install -m 0755 ${WORKDIR}/turnoff_power     ${D}/usr/bin
-       install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
        install -m 0755 ${WORKDIR}/make_mac_sector   ${D}/usr/bin
 
        # rename umountnfs script because it should run before network is disabled
@@ -25,6 +27,10 @@ do_install_append() {
         mv ${D}${sysconfdir}/rc6.d/S31umountnfs.sh ${D}${sysconfdir}/rc6.d/K31umountnfs.sh || /bin/true
 }
 
+do_install_append_mipsel() {
+       install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
+}
+
 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"