[dvbmediasink] Remove WMV patch.
[vuplus_openvuplus_3.0] / meta-bsp / common / recipes / linux / linux-vuplus_3.9.6.bb
index d06d348..44144fc 100644 (file)
@@ -5,20 +5,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
 
 KV = "3.9.6"
 
-PR = "r2"
+PR = "r4"
 SRCREV = ""
 
 MODULE = "linux-3.9.6"
 
 SRC_URI += "http://archive.vuplus.com/download/kernel/stblinux-${KV}.tar.bz2 \
         file://fix_fuse_for_linux_mips_3-9.patch \
+       file://rt2800usb_fix_warn_tx_status_timeout_to_dbg.patch \
         file://${MACHINE}_defconfig \
        "
 
-S = "${WORKDIR}/linux"
-
 inherit kernel
 
+S = "${WORKDIR}/linux"
+
 export OS = "Linux"
 KERNEL_IMAGETYPE = "vmlinux"
 KERNEL_OUTPUT = "vmlinux"
@@ -28,8 +29,7 @@ KERNEL_IMAGEDEST = "tmp"
 FILES_kernel-image = "/${KERNEL_IMAGEDEST}/vmlinux.gz /${KERNEL_IMAGEDEST}/autoexec.bat"
 
 do_configure_prepend() {
-        oe_machinstall -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
-        oe_runmake oldconfig
+        oe_machinstall -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${WORKDIR}/defconfig
 }
 
 kernel_do_install_append() {