Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-bsp / common / recipes / linux / linux-vuplus_3.13.5.bb
index f64b62b..99ff507 100644 (file)
@@ -15,15 +15,15 @@ KERNEL_CONFIG = "${@base_contains("VUPLUS_FEATURES", "dvbproxy", "${MACHINE}_def
 SRC_URI += "http://archive.vuplus.com/download/kernel/stblinux-${KV}.tar.bz2 \
         file://rt2800usb_fix_warn_tx_status_timeout_to_dbg.patch \
         file://linux-tcp_output.patch \
-       file://${KERNEL_CONFIG} \
+        file://${KERNEL_CONFIG} \
        "
 
 SRC_URI += "${@base_contains("VUPLUS_FEATURES", "dvbproxy", "file://linux_dvb_adapter.patch;patch=1;pnum=1", "", d)}"
 
-S = "${WORKDIR}/linux"
-
 inherit kernel
 
+S = "${WORKDIR}/linux"
+
 export OS = "Linux"
 KERNEL_IMAGETYPE = "vmlinux"
 KERNEL_OUTPUT = "vmlinux"
@@ -33,8 +33,7 @@ KERNEL_IMAGEDEST = "tmp"
 FILES_kernel-image = "/${KERNEL_IMAGEDEST}/vmlinux.gz /${KERNEL_IMAGEDEST}/autoexec.bat"
 
 do_configure_prepend() {
-        oe_machinstall -m 0644 ${WORKDIR}/${KERNEL_CONFIG} ${S}/.config
-        oe_runmake oldconfig
+        oe_machinstall -m 0644 ${WORKDIR}/${KERNEL_CONFIG} ${WORKDIR}/defconfig
 }
 
 kernel_do_install_append() {