[minidlna] update 1.1.4
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-webkit / webkit / webkit-gtk_git.bb
1 SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2 HOMEPAGE = "http://www.webkitgtk.org/"
3 BUGTRACKER = "http://bugs.webkit.org/"
4
5 LICENSE = "BSD & LGPLv2+"
6 LIC_FILES_CHKSUM = "\
7         file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
8         file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
9         file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90 \
10         "
11
12 ICU_LIB = "icu"
13
14 DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libidn gnutls geoclue \
15            gtk+ gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
16
17 PR = "r3"
18 PV = "r95199"
19
20 BRANCH="vuplus-webkit"
21 SRCREV="66de070e17c185bbf388688ceb7084b503f743a2"
22
23 SRC_URI = "git://code.vuplus.com:/git/webkit-r95199-base.git;protocol=http;branch=${BRANCH};rev=${SRCREV}"
24
25 inherit autotools lib_package gtk-doc pkgconfig
26
27 S = "${WORKDIR}/git"
28
29 EXTRA_OECONF = "\
30         --enable-debug=no \
31         --with-gtk=2.0 \
32         --disable-spellcheck \
33         --enable-optimizations \
34         --disable-channel-messaging \
35         --disable-meter-tag \
36         --enable-image-resizer \
37         --disable-sandbox \
38         --disable-xpath \
39         --disable-xslt \
40         --disable-svg \
41         --disable-filters \
42         --disable-svg-fonts \
43         --disable-video \
44         --disable-video-track \
45         --with-target=directfb \
46         --disable-jit \
47         --enable-fast-malloc \
48         --enable-shared-workers \
49         --enable-workers \
50         --enable-javascript-debugger \
51         --enable-fast-mobile-scrolling \
52         --enable-offline-web-applications \
53         "
54
55 LDFLAGS += "-Wl,--no-keep-memory"
56
57 EXTRA_AUTORECONF = " -I Source/autotools "
58
59 ARM_INSTRUCTION_SET = "arm"
60
61 COMPATIBLE_HOST_mips64n32 = "null"
62
63 CONFIGUREOPT_DEPTRACK = ""
64
65 do_configure_append() {
66         # somethings wrong with icu, fix it up manually
67         for makefile in $(find ${B} -name "GNUmakefile") ; do
68                 sed -i s:-I/usr/include::g $makefile
69         done
70 }
71
72 do_install_append() {
73         rmdir ${D}${libexecdir}
74         install -d ${D}/usr/bin
75         install -m 0755 ${WORKDIR}/build/Programs/GtkLauncher ${D}/usr/bin/webkit.launcher
76 }
77
78 PACKAGES =+ "${PN}-webinspector bjavascriptcore"
79 FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*"
80 FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/"
81 FILES_${PN} += "${datadir}/webkitgtk-*/resources/error.html \
82                 ${datadir}/webkitgtk-*/images \
83                 ${datadir}/glib-2.0/schemas"
84