[libvupl] added.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-webkit / webkit / webkit-gtk_git.bb
1 SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2 HOMEPAGE = "http://www.webkitgtk.org/"
3 BUGTRACKER = "http://bugs.webkit.org/"
4
5 LICENSE = "BSD & LGPLv2+"
6 LIC_FILES_CHKSUM = "\
7         file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
8         file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
9         file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90 \
10         "
11
12 ICU_LIB = "icu"
13
14 DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libidn gnutls geoclue \
15            gtk+ gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
16
17 PR = "r4"
18 PV = "r95199"
19
20 BRANCH="vuplus-webkit"
21 SRCREV="9eed47d1f873a13759d3fd8ead72739b328d710a"
22
23 SRC_URI = " \
24         git://code.vuplus.com:/git/webkit-r95199-base.git;protocol=http;branch=${BRANCH};rev=${SRCREV} \
25         file://fixed_crash_error.diff \
26 "
27
28 inherit autotools lib_package gtk-doc pkgconfig
29
30 S = "${WORKDIR}/git"
31
32 EXTRA_OECONF = "\
33         --enable-debug=no \
34         --with-gtk=2.0 \
35         --disable-spellcheck \
36         --enable-optimizations \
37         --disable-channel-messaging \
38         --disable-meter-tag \
39         --enable-image-resizer \
40         --disable-sandbox \
41         --disable-xpath \
42         --disable-xslt \
43         --disable-svg \
44         --disable-filters \
45         --disable-svg-fonts \
46         --disable-video \
47         --disable-video-track \
48         --with-target=directfb \
49         --disable-jit \
50         --enable-fast-malloc \
51         --enable-shared-workers \
52         --enable-workers \
53         --enable-javascript-debugger \
54         --enable-fast-mobile-scrolling \
55         --enable-offline-web-applications \
56         "
57
58 LDFLAGS += "-Wl,--no-keep-memory"
59
60 EXTRA_AUTORECONF = " -I Source/autotools "
61
62 ARM_INSTRUCTION_SET = "arm"
63
64 COMPATIBLE_HOST_mips64n32 = "null"
65
66 CONFIGUREOPT_DEPTRACK = ""
67
68 do_configure_append() {
69         # somethings wrong with icu, fix it up manually
70         for makefile in $(find ${B} -name "GNUmakefile") ; do
71                 sed -i s:-I/usr/include::g $makefile
72         done
73 }
74
75 do_install_append() {
76         rmdir ${D}${libexecdir}
77         install -d ${D}/usr/bin
78         install -m 0755 ${WORKDIR}/build/Programs/GtkLauncher ${D}/usr/bin/webkit.launcher
79 }
80
81 PACKAGES =+ "${PN}-webinspector bjavascriptcore"
82 FILES_libjavascriptcore = "${libdir}/libjavascriptcoregtk-1.0.so.*"
83 FILES_${PN}-webinspector = "${datadir}/webkitgtk-*/webinspector/"
84 FILES_${PN} += "${datadir}/webkitgtk-*/resources/error.html \
85                 ${datadir}/webkitgtk-*/images \
86                 ${datadir}/glib-2.0/schemas"
87