Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus_3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / witaistt / enigma2-plugin-extensions-witaispeechtotext.bb
1 DESCRIPTION = "Vuplus wit.ai speech to text plugin"
2
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5
6 DEPENDS = "python-native"
7 RDEPENDS_${PN} = "python-requests enigma2-plugin-systemplugins-bluetoothsetup"
8
9 SRCDATE="20170327"
10 SRCDATE_PR = "r0"
11 PR="${SRCDATE}.${SRCDATE_PR}"
12
13 SRC_URI = " \
14     http://archive.vuplus.com/download/build_support/vuplus/enigma2-plugin-witaispeechtotext-${PR}.tar.gz \
15 "
16
17 S = "${WORKDIR}/enigma2-plugin-witaispeechtotext"
18
19 WITAISPEECHTOTEXT_PLUGIN_PATH = "/usr/lib/enigma2/python/Plugins/Extensions/WitAiSpeechToText"
20
21 do_compile() {
22         python -O -m compileall ${S}
23 }
24
25 do_install() {
26         install -d  ${D}${WITAISPEECHTOTEXT_PLUGIN_PATH}
27         cp -rp ${S}/* ${D}${WITAISPEECHTOTEXT_PLUGIN_PATH}
28 }
29
30 FILES_${PN} = "${WITAISPEECHTOTEXT_PLUGIN_PATH}"
31
32 do_populate_sysroot[noexec] = "1"
33
34 PACKAGE_ARCH = "${MACHINE_ARCH}"
35
36 INSANE_SKIP_${PN} = "already-stripped"
37
38 SRC_URI[md5sum] = "6b1fe4fd6f921a08721e4613b88da485"
39 SRC_URI[sha256sum] = "cfb889fc95a3223783d9448abeaa37b5d17144d19c6278c8d9f24851f51dddb9"
40