Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / vuplus-coldboot / vuplus-coldboot.bb
1 DESCIPTION = "S3 cold boot"
2 MAINTAINER = "vuplus team"
3 LICENSE = "CLOSED"
4
5
6 PV = "1.0"
7 PR = "r3"
8 SRC_REV = ""
9
10 SRC_URI = "file://coldboot \
11            file://coldboot.sh \
12            file://ethwol.sh \
13 "
14
15 do_install() {
16         install -d ${D}/etc/init.d \
17                 ${D}/usr/bin \
18                 ${D}${sysconfdir}/rc0.d 
19
20         install -m 0755 ${WORKDIR}/coldboot.sh ${D}/etc/init.d/coldboot.sh
21         install -m 0755 ${WORKDIR}/ethwol.sh ${D}/etc/init.d/ethwol.sh
22         install -m 0755 ${WORKDIR}/coldboot ${D}/usr/bin/coldboot
23         ln -sf   ../init.d/coldboot.sh ${D}${sysconfdir}/rc0.d/S50coldboot.sh
24         ln -sf   ../init.d/ethwol.sh ${D}${sysconfdir}/rc0.d/K32ethwol.sh
25 }
26
27 INHIBIT_PACKAGE_STRIP = "1"