Solo4K Support.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / usbtunerhelper / usbtunerhelper.bb
1 DESCIPTION = "helper tool to use usb dvb frontends"
2 MAINTAINER = "PLi team"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5
6 PV = "1.0+git${SRCPV}"
7 PR = "r6"
8 SRC_REV = ""
9
10 SRC_URI = " \
11         git://code.vuplus.com/git/vtuner.git;protocol=git;tag=${SRC_REV} \
12         file://no_usb_device.patch;striplevel=1 \
13         file://fix_set_delsys.patch \
14         file://fix_getopt_error.patch \
15         file://get_avail_vtuner.patch \
16         file://setfrontend_ofdm_fecauto.patch \
17         file://${PN}.sh \
18         "
19
20 do_configure_prepend() {
21         sed -i 's/AM_INIT_AUTOMAKE.*$/AM_INIT_AUTOMAKE([foreign subdir-objects])/' ${S}/configure.ac
22 }
23
24 S = "${WORKDIR}/git"
25
26 inherit autotools update-rc.d
27
28 INITSCRIPT_NAME = "${PN}"
29 INITSCRIPT_PARAMS = "defaults"
30 INITSCRIPT_PARAMS = "start 21 2 3 4 5 . stop 20 0 1 6 ."
31
32 do_install_append() {
33         install -d ${D}/etc/init.d
34         install -m 0755 ${WORKDIR}/${PN}.sh ${D}/etc/init.d/${PN}
35 }