Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / usbtunerhelper / usbtunerhelper.bb
1 DESCIPTION = "helper tool to use usb dvb frontends"
2 MAINTAINER = "PLi team"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5
6 PV = "1.0+git${SRCPV}"
7 PR = "r4"
8 SRC_REV = ""
9
10 SRC_URI = " \
11         git://code.vuplus.com/git/vtuner.git;protocol=git;tag=${SRC_REV} \
12         file://no_usb_device.patch;striplevel=1 \
13         file://fix_set_delsys.patch \
14         file://${PN}.sh \
15         "
16
17 do_configure_prepend() {
18         sed -i 's/AM_INIT_AUTOMAKE.*$/AM_INIT_AUTOMAKE([foreign subdir-objects])/' ${S}/configure.ac
19 }
20
21 S = "${WORKDIR}/git"
22
23 inherit autotools update-rc.d
24
25 INITSCRIPT_NAME = "${PN}"
26 INITSCRIPT_PARAMS = "defaults"
27
28 do_install_append() {
29         install -d ${D}/etc/init.d
30         install -m 0755 ${WORKDIR}/${PN}.sh ${D}/etc/init.d/${PN}
31 }