[vuplus-wifi-util] fix default ccode
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / usbtunerhelper / usbtunerhelper.bb
1 DESCIPTION = "helper tool to use usb dvb frontends"
2 MAINTAINER = "PLi team"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5
6 PV = "1.0+git${SRCPV}"
7 PR = "r9"
8 SRC_REV = ""
9
10 SRC_URI = " \
11         git://code.vuplus.com/git/vtuner.git;protocol=git;tag=${SRC_REV} \
12         file://no_usb_device.patch;striplevel=1 \
13         file://fix_set_delsys.patch \
14         file://fix_getopt_error.patch \
15         file://get_avail_vtuner.patch \
16         file://setfrontend_ofdm_fecauto.patch \
17         file://pump_proc_checksize.patch \
18         file://fix_delayed_loading.patch \
19         file://${PN}.sh \
20         "
21
22 SRC_URI += "${@base_version_less_or_equal('VUPLUS_KERNEL_VERSION', '3.13.5', '', 'file://fix_vtuner_def.patch', d)}"
23
24 do_configure_prepend() {
25         sed -i 's/AM_INIT_AUTOMAKE.*$/AM_INIT_AUTOMAKE([foreign subdir-objects])/' ${S}/configure.ac
26 }
27
28 S = "${WORKDIR}/git"
29
30 inherit autotools update-rc.d
31
32 INITSCRIPT_NAME = "${PN}"
33 INITSCRIPT_PARAMS = "defaults"
34 INITSCRIPT_PARAMS = "start 21 2 3 4 5 . stop 20 0 1 6 ."
35
36 do_install_append() {
37         install -d ${D}/etc/init.d
38         install -m 0755 ${WORKDIR}/${PN}.sh ${D}/etc/init.d/${PN}
39 }