Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / tuxbox / tuxbox-common.bb
1 DESCRIPTION = "Tuxbox common files"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
5
6 PN = "tuxbox-common"
7 PR = "r3"
8 SRCDATE = "20090305"
9 PV = "0.0+cvs${SRCDATE}"
10
11 SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox/;module=cdk/root/share/tuxbox;method=ext;tag=dreambox;date=${SRCDATE} \
12         http://dreamboxupdate.com/download/opendreambox/tuxbox-common-r11.tar.gz \
13         file://satellites_20120206.patch;patch=1;pnum=0"
14
15 FILES_${PN} = "/"
16
17 S = "${WORKDIR}/tuxbox-common-r11"
18
19 TRANSPONDER_LISTS = "satellites.xml terrestrial.xml"
20
21 do_install() {
22         install -d ${D}/etc/tuxbox/
23         install -d ${D}/usr/share/tuxbox
24         install -m 0644 ${S}/scart.conf ${D}/etc/tuxbox/scart.conf
25         install -m 0644 ${S}/timezone.xml ${D}/etc/tuxbox/timezone.xml
26         ln -sf /etc/tuxbox/timezone.xml ${D}/etc/
27         ln -sf /usr/share ${D}/share
28
29         for i in ${TRANSPONDER_LISTS}; do
30                 install -m 0644 ${WORKDIR}/tuxbox/$i ${D}/etc/tuxbox/$i
31                 ln -sf /etc/tuxbox/$i ${D}/etc/;
32                 ln -sf /etc/tuxbox/$i ${D}/usr/share/;
33                 ln -sf /etc/tuxbox/$i ${D}/usr/share/tuxbox/;
34         done;
35 }