add openvuplus_mirror
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / tuxbox / tuxbox-common.bb
1 DESCRIPTION = "Tuxbox common files"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
5
6 PN = "tuxbox-common"
7 PR = "r4"
8
9 SRC_REV = "8ef7a7f5f5df5f77197ad279e24b0dc454b8210b"
10
11 SRC_URI = "git://git.code.sf.net/p/tuxbox-cvs/cdk;protocol=git;tag=${SRC_REV} \
12         http://dreamboxupdate.com/download/opendreambox/tuxbox-common-r11.tar.gz;name=tar \
13         file://satellites_20130124.patch;patch=1;pnum=1 \
14 "
15 SRC_URI[tar.md5sum] = "b33829644e7d5be373edabffaf9803f2"
16 SRC_URI[tar.sha256sum] = "3399bb99a59acfcb12a48480d43934f989b0363cab5b5388341196cd5d2a1149"
17
18 FILES_${PN} = "/"
19
20 S = "${WORKDIR}/git/root_dream/share"
21
22 TRANSPONDER_LISTS = "satellites.xml terrestrial.xml"
23
24 do_install() {
25         install -d ${D}/etc/tuxbox/
26         install -d ${D}/usr/share/tuxbox
27         install -m 0644 ${WORKDIR}/tuxbox-common-r11/scart.conf ${D}/etc/tuxbox/scart.conf
28         install -m 0644 ${WORKDIR}/tuxbox-common-r11/timezone.xml ${D}/etc/tuxbox/timezone.xml
29         ln -sf /etc/tuxbox/timezone.xml ${D}/etc/
30         ln -sf /usr/share ${D}/share
31
32         for i in ${TRANSPONDER_LISTS}; do
33                 install -m 0644 ${S}/tuxbox/$i ${D}/etc/tuxbox/$i
34                 ln -sf /etc/tuxbox/$i ${D}/etc/;
35                 ln -sf /etc/tuxbox/$i ${D}/usr/share/;
36                 ln -sf /etc/tuxbox/$i ${D}/usr/share/tuxbox/;
37         done;
38 }