Support gles animation.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / tuxbox / tuxbox-common.bb
1 DESCRIPTION = "Tuxbox common files"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
5
6 PN = "tuxbox-common"
7 PR = "r6"
8
9 SRC_REV = "HEAD"
10
11 SRC_URI = "git://code.vuplus.com/git/dvbapp-meta.git;protocol=git;tag=${SRC_REV} "
12
13 FILES_${PN} = "/"
14
15 S = "${WORKDIR}/git"
16
17 TRANSPONDER_LISTS = "satellites.xml terrestrial.xml"
18
19 do_install() {
20         install -d ${D}/etc/tuxbox/
21         install -d ${D}/usr/share/tuxbox
22         install -m 0644 ${S}/scart.conf ${D}/etc/tuxbox/scart.conf
23         install -m 0644 ${S}/timezone.xml ${D}/etc/tuxbox/timezone.xml
24         ln -sf /etc/tuxbox/timezone.xml ${D}/etc/
25         ln -sf /usr/share ${D}/share
26
27         for i in ${TRANSPONDER_LISTS}; do
28                 install -m 0644 ${S}/$i ${D}/etc/tuxbox/$i
29                 ln -sf /etc/tuxbox/$i ${D}/etc/;
30                 ln -sf /etc/tuxbox/$i ${D}/usr/share/;
31                 ln -sf /etc/tuxbox/$i ${D}/usr/share/tuxbox/;
32         done;
33 }