[vuplus-wifi-util] fix default ccode
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / tuxbox / tuxbox-common.bb
1 DESCRIPTION = "Tuxbox common files"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
5
6 PN = "tuxbox-common"
7 PR = "r7"
8
9 SRC_REV = "12436bfb31dafdc4c73bc4bb5d4cb39a0855c95e"
10
11 SRC_URI = "git://code.vuplus.com/git/dvbapp-meta.git;protocol=git;tag=${SRC_REV} "
12 SRC_URI += "file://add_uhd_channels.patch"
13
14 FILES_${PN} = "/"
15
16 S = "${WORKDIR}/git"
17
18 TRANSPONDER_LISTS = "satellites.xml terrestrial.xml"
19
20 do_install() {
21         install -d ${D}/etc/tuxbox/
22         install -d ${D}/usr/share/tuxbox
23         install -m 0644 ${S}/scart.conf ${D}/etc/tuxbox/scart.conf
24         install -m 0644 ${S}/timezone.xml ${D}/etc/tuxbox/timezone.xml
25         ln -sf /etc/tuxbox/timezone.xml ${D}/etc/
26         ln -sf /usr/share ${D}/share
27
28         for i in ${TRANSPONDER_LISTS}; do
29                 install -m 0644 ${S}/$i ${D}/etc/tuxbox/$i
30                 ln -sf /etc/tuxbox/$i ${D}/etc/;
31                 ln -sf /etc/tuxbox/$i ${D}/usr/share/;
32                 ln -sf /etc/tuxbox/$i ${D}/usr/share/tuxbox/;
33         done;
34 }