Merge remote-tracking branch 'build_test/vuplus-3.0-next' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / lcd4linux / lcd4linux_0.11.0-SVN.bb
1 DESCRIPTION = "LCD4Linux is a small program that grabs information from the kernel and some subsystems and displays it on an external liquid crystal display."
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 DEPENDS = "virtual/libusb0 ncurses readline jpeg dbus sqlite3 mariadb"
6 RDEPENDS_${PN} = "jpeg"
7
8 PV = "0.11.0-SVN"
9 PR = "r2"
10
11 EXTRA_OECONF = " --with-ncurses=${STAGING_LIBDIR}/.."
12
13 SRC_URI = "svn://ssl.bulix.org/svn/lcd4linux/;module=trunk;protocol=https;rev=1200 \
14                 file://lcd4linux.init \
15 "
16
17 S =  "${WORKDIR}/trunk"
18
19 addtask setlibtool before do_configure after do_patch
20
21 do_setlibtool (){
22         sed -i "s#LIBTOOL=libtool#LIBTOOL=\${STAGING_BINDIR_CROSS}\/\${HOST_SYS}-libtool#" ${S}/Makefile.am
23 }
24
25 INITSCRIPT_PARAMS_vuplus = "stop 10 0 6 ."
26 inherit autotools update-rc.d gettext pkgconfig
27
28 INITSCRIPT_NAME = "lcd4linux"
29 CONFFILES_${PN} += "${sysconfdir}/lcd4linux.conf"
30
31 do_install_append() {
32         install -d ${D}/${sysconfdir}
33         install -m 0600 ${S}/lcd4linux.conf.sample  ${D}/${sysconfdir}/lcd4linux.conf
34         install -d ${D}/${INIT_D_DIR}
35         install -m 0755 ${WORKDIR}/lcd4linux.init ${D}/${INIT_D_DIR}/lcd4linux
36 }
37