fix standby name (Standby -> Server Idle Mode, Deep Standby -> Standby)
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=c9e255efa454e0155c1fd758df7dcaf3"
5 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
6         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
7         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
8         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi \
9         hostap-daemon bridge-utils ntfs-3g dosfstools util-linux \
10 "
11
12 RDEPENDS_GST= "gst-plugins-base-decodebin gst-plugins-base-decodebin2 gst-plugins-base-app gst-plugins-bad-fragmented \
13                 gst-plugins-good-id3demux gst-plugins-ugly-mad gst-plugins-base-ogg gst-plugins-base-playbin \
14                 gst-plugins-base-typefindfunctions gst-plugins-base-audioconvert gst-plugins-base-audioresample \
15                 gst-plugins-good-wavparse gst-plugins-ugly-mpegstream \
16                 gst-plugins-good-flac gst-plugin-dvbmediasink gst-plugins-bad-mpegdemux gst-plugins-ugly-dvdsub \
17                 gst-plugins-good-souphttpsrc gst-plugins-ugly-mpegaudioparse gst-plugins-base-subparse \
18                 gst-plugins-good-apetag gst-plugins-good-icydemux gst-plugins-good-autodetect gst-plugins-good-flv \
19                 gst-plugins-bad-mms gst-plugins-ugly-asf gst-plugins-bad-faad \
20 "
21
22 RDEPENDS_${PN} = "python-codecs python-core python-lang python-re python-threading \
23                 python-xml python-fcntl python-stringold python-pickle python-netclient \
24                 glibc-gconv-iso8859-15 ethtool parted \
25                 ${RDEPENDS_GST} \
26 "
27
28 GST_RTSP_RDEPENDS = "gst-plugins-good-udp gst-plugins-good-rtsp gst-plugins-good-rtp gst-plugins-good-rtpmanager"
29 GST_ALSA_RDEPENDS = "gst-plugins-base-alsa alsa-conf"
30 GST_MISC_RDEPENDS = "gst-plugins-good-matroska gst-plugins-good-isomp4 gst-plugins-base-vorbis gst-plugins-good-audioparsers"
31 GST_DVD_RDEPENDS = "gst-plugins-bad-cdxaparse gst-plugins-ugly-cdio gst-plugins-bad-vcdsrc"
32 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
33
34 RDEPENDS_append_vuplus = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugins-good-avi"
35
36 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
37 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
38 #DEPENDS += "enigma2-plugins"
39 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
40
41 SUMMARY_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
42 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
43 SUMMARY_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
44 SUMMARY_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
45 SUMMARY_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
46 SUMMARY_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
47 SUMMARY_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
48 SUMMARY_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
49 SUMMARY_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
50 SUMMARY_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
51 DEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
52 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "python-twisted-web"
53 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "python-twisted-web"
54 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
55 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
56 SUMMARY_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
57 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "python-twisted-mail python-twisted-names python-compression python-mime python-email"
58 SUMMARY_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
59 SUMMARY_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
60 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
61 SUMMARY_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
62 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
63 SUMMARY_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
64 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
65 SUMMARY_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
66 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
67 SUMMARY_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
68 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "python-twisted-mail python-twisted-names python-compression python-mime python-email"
69 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
70
71 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugins-bad-rtmp "
72
73 DEPENDS += "djmount minidlna"
74 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna "
75 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount kernel-module-fuse fuse-utils"
76
77 DEPENDS += "opera-hbbtv"
78 RDEPENDS_enigma2-plugin-extensions-hbbtv = "opera-hbbtv"
79
80 DEPENDS += "wvdial wvstreams ppp usb-modeswitch usb-modeswitch-data"
81 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usb-modeswitch usb-modeswitch-data wvdial wvstreams \
82         kernel-module-ppp-async kernel-module-ppp-deflate kernel-module-ppp-synctty kernel-module-ppp-generic kernel-module-usbserial \
83 "
84
85 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-blkid ntfs-3g dosfstools"
86 RDEPENDS_enigma2-plugin-systemplugins-netdrive = "curlftpfs kernel-module-fuse libfuse2"
87
88 RDEPENDS_enigma2-plugin-systemplugins-backupsuitehdd = "mtd-utils-mkfs.ubifs mtd-utils-nanddump mtd-utils-ubinize"
89 RDEPENDS_enigma2-plugin-systemplugins-backupsuiteusb = "enigma2-plugin-extensions-backupsuitehdd"
90
91 PN = "enigma2"
92 PR = "r68"
93
94 SRCDATE = "20121128"
95 #SRCDATE is NOT used by git to checkout a specific revision
96 #but we need it to build a ipk package version
97 #when you like to checkout a specific revision of e2 you need
98 #have to specify a commit id or a tag name in SRCREV
99
100 ####################################################
101 BRANCH = "vuplus_experimental"
102 PV = "experimental-git${SRCDATE}"
103 SRCREV = ""
104 ####################################################
105
106 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
107
108 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
109            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
110            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
111            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
112            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
113            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
114            file://enigma2_vuplus_addlibpythondeps.patch;patch=1;pnum=1 \
115            file://enigma2_vuplus_pluginbrowser.patch;striplevel=1 \
116            file://enigma2_vuplus_proc_oom_score_adj.patch;striplevel=1 \
117            file://enigma2_vuplus_fix_standby_name.patch \
118            file://enigma2_vuplus_fix_standby_name_skin.patch \
119            file://MyriadPro-Regular.otf \
120            file://MyriadPro-Semibold.otf \
121            file://MyriadPro-SemiboldIt.otf \
122            file://750S \
123            file://Vu_HD \
124            file://number_key \
125            "
126
127 SRC_URI_append = " ${@base_contains("VUPLUS_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
128
129 def change_po():
130         import os
131         try:
132                 os.system("find ./ -name \"*.po\" > ./po_list")
133                 os.system("find ./ -name \"*.pot\" >> ./po_list")
134                 po_list = []
135                 po_list = open('po_list','r+').readlines()
136                 for x in po_list:
137                         changeword(x)
138                 os.system('rm po_list')
139         except:
140                 print 'word patch error '
141                 return
142
143 def changeword(file):
144         fn = file[:-1]
145         fnn = file[:-1]+'_n'
146         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
147         os.system(cmd)
148         cmd1 = "mv "+fnn+" "+fn
149         os.system(cmd1)
150
151 do_unpack_append(){
152         change_po()
153 }
154
155 S = "${WORKDIR}/git"
156
157 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
158 FILES_${PN}-meta = "${datadir}/meta"
159 PACKAGES += "${PN}-meta"
160 PACKAGE_ARCH = "${MACHINE_ARCH}"
161
162 inherit autotools pkgconfig
163
164 do_configure_prepend() {
165         git checkout ${BRANCH}
166 }
167
168 do_compile_prepend_vuplus() {
169         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
170         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
171         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
172         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
173         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
174         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
175         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
176         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
177         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
178         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
179         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
180         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
181         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
182         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
183         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
184 }
185
186 EXTRA_OECONF = " \
187         ${@base_contains("VUPLUS_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
188         ${@base_contains("VUPLUS_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
189         ${@base_contains("VUPLUS_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
190         ${@base_contains("VUPLUS_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
191         BUILD_SYS=${BUILD_SYS} \
192         HOST_SYS=${HOST_SYS} \
193         STAGING_INCDIR=${STAGING_INCDIR} \
194         STAGING_LIBDIR=${STAGING_LIBDIR} \
195 "
196
197 python populate_packages_prepend() {
198         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
199         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/[a-zA-Z0-9_]+.*$', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
200         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
201         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
202         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/(.*/)?\.debug/.*$', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
203 }
204
205 RCONFLICTS_${PN} = "dreambox-keymaps"
206 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
207