Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-transtreamproxy.bb
1 SUMMARY = "streamproxy manages streaming data to a Mobile device using enigma2"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4 SRCREV = "37a3f198a22d90cdfebf07cf56409cf93a4e74ba"
5 PR = "r4"
6
7 SRC_URI = "file://transtreamproxy.xinetd.in \
8            file://transtreamproxy@.service \
9            file://transtreamproxy.socket \
10            file://transcoding.patch;patch=1;pnum=1 \
11 "
12
13 SCHWERKRAFT_PROJECT = "streamproxy"
14
15 inherit autotools schwerkraft-git systemd xinetd
16
17 do_install() {
18         install -d ${D}/usr/bin
19         install -m 0755 ${S}/src/streamproxy      ${D}/usr/bin/transtreamproxy
20         install -d ${D}${systemd_unitdir}/system
21         ln -sf /dev/null ${D}${systemd_unitdir}/system/transtreamproxy.service
22 }
23
24 SYSTEMD_PACKAGES = "${PN}-systemd"
25 SYSTEMD_SERVICE_${PN}-systemd = "transtreamproxy.socket"
26
27 XINETD_PACKAGES = "${PN}-xinetd"
28 XINETD_SERVICE_${PN}-xinetd = "transtreamproxy"