Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus_3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-transtreamproxy.bb
1 SUMMARY = "streamproxy manages streaming data to a Mobile device using enigma2"
2 PRIORITY = "required"
3 LICENSE = "GPLv3"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6 inherit gitpkgv
7
8 PR = "r11"
9
10 PV = "0.1+git${SRCPV}"
11 PKGV = "0.1+git${GITPKGV}"
12 SRCREV_pn-${PN} ?= "${AUTOREV}"
13
14 DEPENDS += "boost"
15 SRC_URI = "\
16         git://code.vuplus.com/git/filestreamproxy.git;protocol=git;branch=transtreamproxy \
17         "
18 inherit autotools-brokensep
19
20 EXTRA_OECONF_vusolo4k += " --enable-ext-pid "
21 EXTRA_OECONF_vuultimo4k += " --enable-ext-pid "
22 EXTRA_OECONF_vuuno4k += " --enable-ext-pid "
23 EXTRA_OECONF_vuuno4kse += " --enable-ext-pid "
24
25 S = "${WORKDIR}/git"
26
27 do_install() {
28         install -d ${D}/usr/bin
29         install -m 0755 ${S}/src/transtreamproxy ${D}/usr/bin/transtreamproxy
30 }
31
32 PACKAGE_ARCH = "${MACHINE_ARCH}"
33