e50eccb4da14e50477e8d59fe947650621443c3c
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-plugins.bb
1 DESCRIPTION = "Additional plugins for Enigma2"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "Proprietary"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=8e37f34d0e40d32ea2bc90ee812c9131"
5
6 PACKAGES_DYNAMIC = "enigma2-plugin-*"
7
8 # if you want experimental, use:
9 #SRCREV="87fd2f1120962f553ecb1a88bbee46ed821df975"
10 SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
11 SRCDATE="20110215"
12 BRANCH="master"
13 PV = "experimental-git${SRCDATE}"
14 PR = "r10"
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
17
18 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
19
20 EXTRA_OECONF = " \
21         BUILD_SYS=${BUILD_SYS} \
22         HOST_SYS=${HOST_SYS} \
23         STAGING_INCDIR=${STAGING_INCDIR} \
24         STAGING_LIBDIR=${STAGING_LIBDIR} \
25 "
26
27 SRC_URI_append_vuplus = " \
28         file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
29         file://enigma2_plugins_20121113.patch;patch=1;pnum=1 \
30         file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
31         file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
32         file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
33         file://enigma2_plugins_fancontrol2.patch;patch=1;pnum=1 \
34         file://enigma2_plugins_gst_plugins_pkgname.patch;patch=1;pnum=1 \
35         file://dreamboxweb.png \
36         file://dreamboxwebtv.png \
37         file://favicon.ico \
38         file://Makefile.am
39 "
40
41 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
42 FILES_${PN}-meta = "${datadir}/meta"
43 PACKAGES += "${PN}-meta"
44 PACKAGE_ARCH = "${MACHINE_ARCH}"
45
46 inherit autotools
47
48 S = "${WORKDIR}/git"
49
50 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
51 DEPENDS += "enigma2"
52
53 def modify_po():
54     import os
55     try:
56         os.system("find ./ -name \"*.po\" > ./po_list")
57         os.system("find ./ -name \"*.pot\" >> ./po_list")
58         po_list = []
59         po_list = open('po_list','r+').readlines()
60         for x in po_list:
61             changeword1(x)
62         changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
63         changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
64         os.system('rm po_list')
65     except:
66         print 'word patch error '
67         return
68
69 def changeword1(file):
70     fn = file[:-1]
71     fnn = file[:-1]+'_n'
72     cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
73     os.system(cmd)
74     cmd1 = "mv "+fnn+" "+fn
75     os.system(cmd1)
76
77 def changeword2(file):
78     fn = file[:-1]
79     fnn = file[:-1]+'_n'
80     cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
81     os.system(cmd)
82     cmd1 = "mv "+fnn+" "+fn
83     os.system(cmd1)
84
85 do_unpack_append(){
86         modify_po()
87 }
88
89 do_configure_prepend_vuplus() {
90         cp -av ${WORKDIR}/Makefile.am ${S}/easymedia/po/
91 }
92
93 do_install_append_vuplus() {
94         install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
95         install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
96         install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
97 }
98
99 python populate_packages_prepend() {
100     enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
101     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
102     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
103     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
104     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/\.debug/', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
105     def parseControlFile(dir, d, package):
106         import os
107         #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
108         #so the foldername is still ac3lipsync
109         if package == 'audiosync':
110             package = 'ac3lipsync'
111         src = open(dir + "/" + package.split('-')[-1] + "/CONTROL/control").read()
112         for line in src.splitlines():
113             name, value = line.strip().split(': ', 1)
114             if name == 'Description':
115                 d.setVar('DESCRIPTION_' + package, value)
116             elif name == 'Depends':
117                 d.setVar('RDEPENDS_' + package, ' '.join(value.split(', ')))
118             elif name == 'Replaces':
119                 d.setVar('RREPLACES_' + package, ' '.join(value.split(', ')))
120             elif name == 'Conflicts':
121                 d.setVar('RCONFLICTS_' + package, ' '.join(value.split(', ')))
122     srcdir = d.getVar('S', True)
123     for package in d.getVar('PACKAGES', True).split():
124         if package.startswith('enigma2-plugin-') and not package.endswith('-dev') and not package.endswith('-dbg') and not package.endswith('-staticdev'):
125             parseControlFile(srcdir, d, package)
126 }