Remove warning messages.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-plugins.bb
1 DESCRIPTION = "Additional plugins for Enigma2"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "Proprietary"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=8e37f34d0e40d32ea2bc90ee812c9131"
5
6 PACKAGES_DYNAMIC = "enigma2-plugin-*"
7
8 # if you want experimental, use:
9 #SRCREV="87fd2f1120962f553ecb1a88bbee46ed821df975"
10 SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
11 SRCDATE="20110215"
12 BRANCH="master"
13 PV = "experimental-git${SRCDATE}"
14 PR = "r12"
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
17
18 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
19
20 EXTRA_OECONF = " \
21         BUILD_SYS=${BUILD_SYS} \
22         HOST_SYS=${HOST_SYS} \
23         STAGING_INCDIR=${STAGING_INCDIR} \
24         STAGING_LIBDIR=${STAGING_LIBDIR} \
25         --with-gstversion=1.0 \
26 "
27
28 SRC_URI_append_vuplus = " \
29         file://enigma2_plugins_mytube_tpm.patch \
30         file://enigma2_plugins_20121113.patch \
31         file://enigma2_plugins_webinterface_tpm.patch \
32         file://enigma2_plugins_ac3lipsync_dolby.patch \
33         file://enigma2_plugins_autoresolution_fix.patch \
34         file://enigma2_plugins_fancontrol2.patch \
35         file://enigma2_plugins_gst10_support.patch \
36         file://enigma2_plugins_fix_depends_pkgname.patch \
37         file://dreamboxweb.png \
38         file://dreamboxwebtv.png \
39         file://favicon.ico \
40         file://Makefile.am \
41 "
42
43 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
44 FILES_${PN}-meta = "${datadir}/meta"
45 PACKAGES += "${PN}-meta"
46 PACKAGE_ARCH = "${MACHINE_ARCH}"
47
48 inherit autotools-brokensep pythonnative pkgconfig
49
50 S = "${WORKDIR}/git"
51
52 DEPENDS = " \
53         enigma2 \
54         python-pyopenssl \
55         python-gdata \
56         streamripper \
57         python-mutagen \
58         python-daap \
59         enigma2-plugin-extensions-openwebif \
60         gstreamer1.0-plugins-bad \
61         "
62
63 def modify_po():
64     import os
65     try:
66         os.system("find ./ -name \"*.po\" > ./po_list")
67         os.system("find ./ -name \"*.pot\" >> ./po_list")
68         po_list = []
69         po_list = open('po_list','r+').readlines()
70         for x in po_list:
71             changeword1(x)
72         changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
73         changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
74         os.system('rm po_list')
75     except:
76         print 'word patch error '
77         return
78
79 def changeword1(file):
80     fn = file[:-1]
81     fnn = file[:-1]+'_n'
82     cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
83     os.system(cmd)
84     cmd1 = "mv "+fnn+" "+fn
85     os.system(cmd1)
86
87 def changeword2(file):
88     fn = file[:-1]
89     fnn = file[:-1]+'_n'
90     cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
91     os.system(cmd)
92     cmd1 = "mv "+fnn+" "+fn
93     os.system(cmd1)
94
95 do_unpack_append(){
96     modify_po()
97 }
98
99 do_configure_prepend_vuplus() {
100         cp -av ${WORKDIR}/Makefile.am ${S}/easymedia/po/
101 }
102
103 do_install_append_vuplus() {
104         install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
105         install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
106         install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
107 }
108
109 python populate_packages_prepend() {
110     enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
111     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
112     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
113     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
114     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/\.debug/', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
115     def parseControlFile(dir, d, package):
116         import os
117         #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
118         #so the foldername is still ac3lipsync
119         if package == 'audiosync':
120             package = 'ac3lipsync'
121         src = open(dir + "/" + package.split('-')[-1] + "/CONTROL/control").read()
122         for line in src.splitlines():
123             name, value = line.strip().split(': ', 1)
124             if name == 'Description':
125                 d.setVar('DESCRIPTION_' + package, value)
126             elif name == 'Depends':
127                 rdepends = []
128                 for depend in value.split(','):
129                     depend = depend.strip()
130                     if depend.startswith('enigma2') and not depend.startswith('enigma2-'):
131                         rdepends.append('enigma2')
132                     else:
133                         rdepends.append(depend)
134                 d.setVar('RDEPENDS_' + package, ' '.join(rdepends))
135             elif name == 'Replaces':
136                 d.setVar('RREPLACES_' + package, ' '.join(value.split(', ')))
137             elif name == 'Conflicts':
138                 d.setVar('RCONFLICTS_' + package, ' '.join(value.split(', ')))
139     srcdir = d.getVar('S', True)
140     for package in d.getVar('PACKAGES', True).split():
141         if package.startswith('enigma2-plugin-') and not package.endswith('-dev') and not package.endswith('-dbg') and not package.endswith('-staticdev'):
142             parseControlFile(srcdir, d, package)
143 }