relocate packages on recipes-base/recipes-enigma2/recipes-wlan.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-plugins.bb
1 DESCRIPTION = "Additional plugins for Enigma2"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "Proprietary"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=8e37f34d0e40d32ea2bc90ee812c9131"
5
6 PACKAGES_DYNAMIC = "enigma2-plugin-*"
7
8 # if you want experimental, use:
9 #SRCREV="87fd2f1120962f553ecb1a88bbee46ed821df975"
10 SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
11 SRCDATE="20110215"
12 BRANCH="master"
13 PV = "experimental-git${SRCDATE}"
14 PR = "r5"
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/vuplus:"
17
18 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
19
20 EXTRA_OECONF = " \
21         BUILD_SYS=${BUILD_SYS} \
22         HOST_SYS=${HOST_SYS} \
23         STAGING_INCDIR=${STAGING_INCDIR} \
24         STAGING_LIBDIR=${STAGING_LIBDIR} \
25 "
26
27 SRC_URI_append_vuplus = " \
28            file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
29            file://enigma2_plugins_20110810.patch;patch=1;pnum=1 \
30            file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
31            file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
32            file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
33            file://enigma2_plugins_dependency.patch;patch=1;pnum=1 \
34            file://dreamboxweb.png \
35            file://dreamboxwebtv.png \
36            file://favicon.ico"
37
38 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
39 FILES_${PN}-meta = "${datadir}/meta"
40 PACKAGES += "${PN}-meta"
41 PACKAGE_ARCH = "${MACHINE_ARCH}"
42
43 inherit autotools
44
45 S = "${WORKDIR}/git"
46
47 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
48 DEPENDS += "enigma2"
49
50 def modify_po():
51         import os
52         try:
53                 os.system("find ./ -name \"*.po\" > ./po_list")
54                 os.system("find ./ -name \"*.pot\" >> ./po_list")
55                 po_list = []
56                 po_list = open('po_list','r+').readlines()
57                 for x in po_list:
58                         changeword1(x)
59                 changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
60                 changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
61                 os.system('rm po_list')
62         except:
63                 print 'word patch error '
64                 return
65
66 def changeword1(file):
67         fn = file[:-1]
68         fnn = file[:-1]+'_n'
69         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
70         os.system(cmd)
71         cmd1 = "mv "+fnn+" "+fn
72         os.system(cmd1)
73
74 def changeword2(file):
75         fn = file[:-1]
76         fnn = file[:-1]+'_n'
77         cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
78         os.system(cmd)
79         cmd1 = "mv "+fnn+" "+fn
80         os.system(cmd1)
81
82 do_unpack_append(){
83         modify_po()
84 }
85
86
87 do_install_append_vuplus() {
88         install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
89         install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
90         install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
91 }
92
93 python populate_packages_prepend() {
94         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
95         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
96         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
97         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
98         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/\.debug/', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
99         def parseControlFile(dir, d, package):
100                 import os
101                 #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
102                 #so the foldername is still ac3lipsync
103                 if package == 'audiosync':
104                         package = 'ac3lipsync'
105                 src = open(dir + "/" + package.split('-')[-1] + "/CONTROL/control").read()
106                 for line in src.splitlines():
107                         name, value = line.strip().split(': ', 1)
108                         if name == 'Description':
109                                 d.setVar('DESCRIPTION_' + package, value)
110                         elif name == 'Depends':
111                                 d.setVar('RDEPENDS_' + package, ' '.join(value.split(', ')))
112                         elif name == 'Replaces':
113                                 d.setVar('RREPLACES_' + package, ' '.join(value.split(', ')))
114                         elif name == 'Conflicts':
115                                 d.setVar('RCONFLICTS_' + package, ' '.join(value.split(', ')))
116         srcdir = d.getVar('S', True)
117         for package in d.getVar('PACKAGES', True).split():
118                 if package.startswith('enigma2-plugin-') and not package.endswith('-dev') and not package.endswith('-dbg') and not package.endswith('-staticdev'):
119                         parseControlFile(srcdir, d, package)
120 }