fixed do_install bug.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-plugins.bb
1 DESCRIPTION = "Additional plugins for Enigma2"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "Proprietary"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=8e37f34d0e40d32ea2bc90ee812c9131"
5
6 PACKAGES_DYNAMIC = "enigma2-plugin-*"
7
8 # if you want experimental, use:
9 #SRCREV="87fd2f1120962f553ecb1a88bbee46ed821df975"
10 SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
11 SRCDATE="20110215"
12 BRANCH="master"
13 PV = "experimental-git${SRCDATE}"
14 PR = "r9"
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
17
18 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
19
20 EXTRA_OECONF = " \
21         BUILD_SYS=${BUILD_SYS} \
22         HOST_SYS=${HOST_SYS} \
23         STAGING_INCDIR=${STAGING_INCDIR} \
24         STAGING_LIBDIR=${STAGING_LIBDIR} \
25 "
26
27 SRC_URI_append_vuplus = " \
28            file://enigma2_plugins_mytube_tpm.patch;patch=1;pnum=1 \
29            file://enigma2_plugins_20121113.patch;patch=1;pnum=1 \
30            file://enigma2_plugins_webinterface_tpm.patch;patch=1;pnum=1 \
31            file://enigma2_plugins_ac3lipsync_dolby.patch;patch=1;pnum=1 \
32            file://enigma2_plugins_autoresolution_fix.patch;patch=1;pnum=1 \
33            file://enigma2_plugins_dependency.patch;patch=1;pnum=1 \
34            file://enigma2_plugins_gst_plugins_pkgname.patch;patch=1;pnum=1 \
35            file://dreamboxweb.png \
36            file://dreamboxwebtv.png \
37            file://favicon.ico \
38            file://Makefile.am "
39
40 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
41 FILES_${PN}-meta = "${datadir}/meta"
42 PACKAGES += "${PN}-meta"
43 PACKAGE_ARCH = "${MACHINE_ARCH}"
44
45 inherit autotools
46
47 S = "${WORKDIR}/git"
48
49 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
50 DEPENDS += "enigma2"
51
52 def modify_po():
53         import os
54         try:
55                 os.system("find ./ -name \"*.po\" > ./po_list")
56                 os.system("find ./ -name \"*.pot\" >> ./po_list")
57                 po_list = []
58                 po_list = open('po_list','r+').readlines()
59                 for x in po_list:
60                         changeword1(x)
61                 changeword1('enigma2-plugins/networkwizard/src/networkwizard.xml ')
62                 changeword2('enigma2-plugins/webinterface/src/web-data/tpl/default/index.html ')
63                 os.system('rm po_list')
64         except:
65                 print 'word patch error '
66                 return
67
68 def changeword1(file):
69         fn = file[:-1]
70         fnn = file[:-1]+'_n'
71         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
72         os.system(cmd)
73         cmd1 = "mv "+fnn+" "+fn
74         os.system(cmd1)
75
76 def changeword2(file):
77         fn = file[:-1]
78         fnn = file[:-1]+'_n'
79         cmd = "sed s/Dreambox/Vu+/g "+fn+" > "+fnn
80         os.system(cmd)
81         cmd1 = "mv "+fnn+" "+fn
82         os.system(cmd1)
83
84 do_unpack_append(){
85         modify_po()
86 }
87
88 do_configure_prepend_vuplus() {
89         cp -av ${WORKDIR}/Makefile.am ${S}/easymedia/po/
90 }
91
92 do_install_append_vuplus() {
93         install -m 0644 ${WORKDIR}/dreamboxweb.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
94         install -m 0644 ${WORKDIR}/dreamboxwebtv.png ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/tpl/default/streaminterface/img
95         install -m 0644 ${WORKDIR}/favicon.ico ${D}/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/web-data/img/
96 }
97
98 python populate_packages_prepend() {
99         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
100         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
101         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
102         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
103         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+).*/\.debug/', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
104         def parseControlFile(dir, d, package):
105                 import os
106                 #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
107                 #so the foldername is still ac3lipsync
108                 if package == 'audiosync':
109                         package = 'ac3lipsync'
110                 src = open(dir + "/" + package.split('-')[-1] + "/CONTROL/control").read()
111                 for line in src.splitlines():
112                         name, value = line.strip().split(': ', 1)
113                         if name == 'Description':
114                                 d.setVar('DESCRIPTION_' + package, value)
115                         elif name == 'Depends':
116                                 d.setVar('RDEPENDS_' + package, ' '.join(value.split(', ')))
117                         elif name == 'Replaces':
118                                 d.setVar('RREPLACES_' + package, ' '.join(value.split(', ')))
119                         elif name == 'Conflicts':
120                                 d.setVar('RCONFLICTS_' + package, ' '.join(value.split(', ')))
121         srcdir = d.getVar('S', True)
122         for package in d.getVar('PACKAGES', True).split():
123                 if package.startswith('enigma2-plugin-') and not package.endswith('-dev') and not package.endswith('-dbg') and not package.endswith('-staticdev'):
124                         parseControlFile(srcdir, d, package)
125 }