update packages.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
1 MODULE = "OpenWebif"
2 DESCRIPTION = "Control your receiver with a browser"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
5
6 DEPENDS = "python-cheetah-native"
7 RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl aio-grab"
8
9 inherit gitpkgv
10 PV = "0.1+git${SRCPV}"
11 PKGV = "0.1+git${GITPKGV}"
12 PR = "r0.73"
13
14 require openplugins.inc
15
16 # Just a quick hack to "compile" it
17 do_compile() {
18         cheetah-compile -R --nobackup ${S}/plugin
19         python -O -m compileall ${S}
20 }
21
22 PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
23 do_install() {
24         install -d ${D}${PLUGINPATH}
25         cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
26 }
27
28 FILES_${PN} = "${PLUGINPATH}"
29 PACKAGES = "${PN}"