Merge remote-tracking branch 'oe21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
1 MODULE = "OpenWebif"
2 DESCRIPTION = "Control your receiver with a browser"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
5
6 DEPENDS = "python-cheetah-native"
7 RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl \
8                 python-shell aio-grab python-compression python-numbers python-zopeinterface \
9 "
10
11 SRCREV_pn-${PN}="c30a9aefcf87387e90f0ddbac61ef1aada8cbd6c"
12 inherit gitpkgv
13 PV = "1+git${SRCPV}"
14 PKGV = "1+git${GITPKGV}"
15
16 require openplugins-distutils.inc
17
18 # Just a quick hack to "compile" it
19 do_compile() {
20         cheetah-compile -R --nobackup ${S}/plugin
21         python -O -m compileall ${S}
22 }
23
24 PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
25 do_install_append() {
26         install -d ${D}${PLUGINPATH}
27         cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
28 }
29
30 FILES_${PN} = "${PLUGINPATH}"