e2e91ad19fb962ddf526a1548f5d7612dc393349
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
1 MODULE = "OpenWebif"
2 DESCRIPTION = "Control your receiver with a browser"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
5
6 DEPENDS = "python-cheetah-native"
7 RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl \
8                 python-shell aio-grab python-compression python-numbers python-zopeinterface \
9 "
10
11 inherit gitpkgv
12 PV = "1+git${SRCPV}"
13 PKGV = "1+git${GITPKGV}"
14
15 require openplugins-distutils.inc
16
17 # Just a quick hack to "compile" it
18 do_compile() {
19         cheetah-compile -R --nobackup ${S}/plugin
20         python -O -m compileall ${S}
21 }
22
23 PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
24 do_install_append() {
25         install -d ${D}${PLUGINPATH}
26         cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
27 }
28
29 FILES_${PN} = "${PLUGINPATH}"