bdf224208c682ad762d28973e59f4239405366c5
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
1 MODULE = "OpenWebif"
2 DESCRIPTION = "Control your receiver with a browser"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
5
6 DEPENDS = "python-cheetah-native"
7 RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl aio-grab"
8
9 inherit gitpkgv
10 PV = "0.1+git${SRCPV}"
11 PKGV = "0.1+git${GITPKGV}"
12 PR = "r0.73"
13
14 require openplugins.inc
15
16 SRC_URI += "file://openwebif_8001_8002.patch;patch=1;pnum=1"
17
18 # Just a quick hack to "compile" it
19 do_compile() {
20         cheetah-compile -R --nobackup ${S}/plugin
21         python -O -m compileall ${S}
22 }
23
24 PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
25 do_install() {
26         install -d ${D}${PLUGINPATH}
27         cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
28 }
29
30 FILES_${PN} = "${PLUGINPATH}"
31 PACKAGES = "${PN}"