7ab61a1e8a5da8c7f3f1a3bbd773e7fbd99f5781
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
1 MODULE = "OpenWebif"
2 DESCRIPTION = "Control your receiver with a browser"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
5
6 DEPENDS = "python-cheetah-native"
7 RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl \
8                 python-shell aio-grab python-compression python-numbers python-zopeinterface \
9 "
10
11 SRCREV_pn-${PN}="d84307958746e6a597b43defe5bd1cb78fd745c8"
12 inherit gitpkgv
13 PV = "1+git${SRCPV}"
14 PKGV = "1+git${GITPKGV}"
15 PR = "r1"
16
17 require openplugins-distutils.inc
18
19 SRC_URI += " file://openwebif_solo4k.patch;striplevel=1 "
20
21 # Just a quick hack to "compile" it
22 do_compile() {
23         cheetah-compile -R --nobackup ${S}/plugin
24         python -O -m compileall ${S}
25 }
26
27 PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
28 do_install_append() {
29         install -d ${D}${PLUGINPATH}
30         cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
31 }
32
33 python do_package_prepend () {
34   boxtypes = [
35   ('bm750', 'duo.jpg', 'vu_normal.png'),
36   ('vuduo2', 'duo2.jpg', 'vu_duo2.png'),
37   ('vusolo', 'solo.jpg', 'vu_normal.png'),
38   ('vusolo2', 'solo2.jpg', 'vu_normal.png'),
39   ('vusolose', 'solose.jpg', 'vu_normal.png'),
40   ('vuzero', 'zero.jpg', 'vu_normal.png'),
41   ('vuultimo', 'ultimo.jpg', 'vu_ultimo.png'),
42   ('vuuno', 'uno.jpg', 'vu_normal.png'),
43   ]
44   import os
45   top = '${D}${PLUGINPATH}/public/images/'
46   target_box = 'unknown.jpg'
47   target_remote = 'ow_remote.png'
48   for x in boxtypes:
49     if x[0] == '${MACHINE}':
50       target_box = x[1]
51       target_remote = x[2]
52       break
53   for root, dirs, files in os.walk(top + 'boxes', topdown=False):
54     for name in files:
55       if target_box != name and name != 'unknown.jpg':
56         os.remove(os.path.join(root, name))
57   for root, dirs, files in os.walk(top + 'remotes', topdown=False):
58     for name in files:
59       if target_remote != name and name != 'ow_remote.png':
60         os.remove(os.path.join(root, name))
61 }
62
63 FILES_${PN} = "${PLUGINPATH}"