Merge remote-tracking branch 'OE-2.1/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / dreambox-dvbincludes / dreambox-dvbincludes.bb
1 SUMMARY = "This package provides dbox2/dreambox \
2 compatible header files for the API to the drivers."
3
4 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
5
6 PV="1"
7 PR="1.1.1"
8 LICENSE = "GPLv2+"
9 LIC_FILES_CHKSUM = "file://dbox/avs_core.h;beginline=1;endline=21;md5=b2ab401756a0768647ae13acb2e325ab"
10
11 SRC_URI = "http://sources.dreamboxupdate.com/snapshots/include2.tar.gz"
12 SRC_URI[md5sum] = "9d236095a88d7ce9f3bf0503ee5237d6"
13 SRC_URI[sha256sum] = "739bc35bccdb1e4c6e14b77ab86808354eb6fd75434d3bd6236f3b3346805e02"
14
15 S = "${WORKDIR}/include"
16
17 ALLOW_EMPTY_dreambox-dvbincludes = "1"
18
19 INPUT_FILES = "input_fake.h ci/ci.h  dbox/avia_gt_pig.h dbox/avs_core.h \
20         dbox/event.h dbox/fp.h dbox/info.h dbox/lcd.h dbox/saa7126_core.h \
21         dbox/lcd-ks0713.h dbox/fb.h \
22         dreambox/dreaminfo.h \
23         tuxbox/hardware_dbox2.h tuxbox/hardware_dreambox.h tuxbox/hardware_pci.h \
24         tuxbox/info.h tuxbox/info_dbox2.h tuxbox/kernel.h"
25
26 do_install() {
27         install -d ${STAGING_INCDIR}/ci
28         install -d ${STAGING_INCDIR}/dbox
29         install -d ${STAGING_INCDIR}/dreambox
30         install -d ${STAGING_INCDIR}/tuxbox
31         for f in ${INPUT_FILES}; do
32                 install -m 0644 ${S}/$f ${STAGING_INCDIR}/$f
33         done;
34 }
35