update drivers(duo2, solo2, solose, zero, solo4k, uno4k, ultimo4k)
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / bluetoothsetup / enigma2-plugin-systemplugins-bluetoothsetup.bb
1 DESCRIPTION = "Vuplus bluetooth plugin"
2
3 LICENSE = "CLOSED"
4
5 DEPENDS = "python-native"
6 RDEPENDS_${PN} = "vuplus-bluetooth-util"
7
8 SRCDATE="20161128"
9 SRCDATE_PR = "r0"
10 PR="${SRCDATE}.${SRCDATE_PR}"
11
12 SRC_URI = " \
13     http://archive.vuplus.com/download/build_support/vuplus/enigma2-plugin-bluetoothsetup-${MACHINE}-${PR}.tar.gz \
14 "
15
16 S = "${WORKDIR}/plugin"
17
18 BLUETOOTH_PLUGIN_PATH = "/usr/lib/enigma2/python/Plugins/SystemPlugins/BluetoothSetup"
19
20 do_compile() {
21         python -O -m compileall ${S}
22 }
23
24 do_install() {
25         install -d  ${D}${BLUETOOTH_PLUGIN_PATH}
26         cp -rp ${S}/* ${D}${BLUETOOTH_PLUGIN_PATH}
27 }
28
29 FILES_${PN} = "${BLUETOOTH_PLUGIN_PATH}"
30
31 do_populate_sysroot[noexec] = "1"
32
33 PACKAGE_ARCH = "${MACHINE_ARCH}"
34
35 INSANE_SKIP_${PN} = "already-stripped"
36
37 SRC_URI[md5sum] = "af348a34715e380329b2618103bf3498"
38 SRC_URI[sha256sum] = "634e39992eabd6a3146bd8ed59cc85bb019da33019ee2e356ca77ff607321493"