remove nss library from chromium package.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-support / taglib / taglib_1.8.bb
1 DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2 SECTION = "libs/multimedia"
3 HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
4 LICENSE = "LGPLv2.1 | MPL-1"
5 LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
6                     file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
7                     file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
8
9 DEPENDS = "zlib"
10
11 PR = "r0"
12 # http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz
13 SRC_URI = "https://github.com/downloads/taglib/taglib/taglib-1.8.tar.gz \
14            "
15
16 SRC_URI[md5sum] = "dcb8bd1b756f2843e18b1fdf3aaeee15"
17 SRC_URI[sha256sum] = "66d33481703c90236a0a9d1c38fd81b584ca7109ded049225f5463dcaffc209a"
18
19 S = "${WORKDIR}/taglib-${PV}"
20
21 inherit cmake pkgconfig binconfig
22
23 PACKAGES =+ "${PN}-c"
24 FILES_${PN}-c = "${libdir}/libtag_c.so.*"
25
26 do_configure_prepend () {
27         rm -f ${S}/admin/ltmain.sh
28         rm -f ${S}/admin/libtool.m4.in
29 }
30