[vuplus-wifi-util] fix default ccode
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-support / taglib / taglib_1.11.1.bb
1 SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
2 SECTION = "libs/multimedia"
3 HOMEPAGE = "http://taglib.github.io/"
4 LICENSE = "LGPLv2.1 | MPL-1"
5 LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
6                     file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
7                     file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
8
9 DEPENDS = "zlib"
10
11 SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
12 SRC_URI[md5sum] = "cee7be0ccfc892fa433d6c837df9522a"
13 SRC_URI[sha256sum] = "b6d1a5a610aae6ff39d93de5efd0fdc787aa9e9dc1e7026fa4c961b26563526b"
14
15 UPSTREAM_CHECK_URI = "http://github.com/taglib/taglib/releases/"
16
17 BINCONFIG = "${bindir}/taglib-config"
18
19 inherit cmake pkgconfig binconfig
20
21 PACKAGES =+ "${PN}-c"
22 FILES_${PN}-c = "${libdir}/libtag_c.so.*"
23
24 EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
25                  -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
26                  -DHAVE_BOOST_BYTESWAP=FALSE \
27                  -DCMAKE_CXX_STANDARD=11 \
28                  -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
29 "
30 CXXFLAGS += "-std=c++11"
31
32 do_configure_prepend () {
33         rm -f ${S}/admin/ltmain.sh
34         rm -f ${S}/admin/libtool.m4.in
35 }
36
37 # without -fPIC depending packages failed with many error like:
38 # | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
39 CXXFLAGS += "-fPIC"