Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-support / libxmlccwrap / libxmlccwrap_0.0.12.bb
1 SUMMARY = "A small libxml2 c++ wrapper"
2 AUTHOR = "Jürgen Rinas <jrinas@gmx.de>"
3 HOMEPAGE = "http://www.ant.uni-bremen.de/whomes/rinas/libxmlccwrap/"
4 SECTION = "libs"
5 LICENSE = "LGPLv2.1+"
6 LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
7 DEPENDS = "libxml2"
8 PR = "r1"
9
10 SRC_URI = "http://www.ant.uni-bremen.de/whomes/rinas/libxmlccwrap/download/${P}.tar.gz \
11            file://dont_build_unneeded.patch \
12            file://disable_libxslt.patch \
13            file://fix_assignment_operator.patch \
14            file://use-pkgconfig.patch \
15 "
16
17 SRC_URI[md5sum] = "9f8bbad3452d704603246273b2dda758"
18 SRC_URI[sha256sum] = "38fb5f75f8b7dad1c8d535cc7b18ea9f1603e14a8b9256a2f60cf721513dc299"
19
20 inherit autotools pkgconfig
21
22 FILES_${PN} = "${libdir}/${P}${SOLIBSDEV}"
23 FILES_${PN}-dev = "${includedir} ${libdir}/${PN}${SOLIBSDEV} ${libdir}/*.la"