[lzma] remove the recipe (xz from oe-core include lzma).
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / xbmc / xbmc_git.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 SUMMARY = "XBMC Media Center"
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff"
6
7 DEPENDS = "libgles libxslt libusb1 libcec libplist expat yajl gperf-native fribidi mpeg2dec samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0  bzip2 virtual/libsdl jasper zip-native zlib libtinyxml taglib libbluray libshairport librtmp zlib libnfs libxslt"
8
9 RDEPENDS_${PN} = "python"
10 RDEPENDS_${PN} += "\
11         python-distutils \
12         python-subprocess \
13         python-robotparser \
14         python-mechanize \
15         python-threading \
16         python-shell \
17         python-zlib \
18         python-sqlite3 \
19         python-json \
20         python-xml \
21         python-html \
22         python-netserver \
23         python-misc \
24         python-pygobject \
25         python-pygobject-lib \
26         python-textutils \
27         python-simplejson \
28         python-xmlrpc   \
29         python-pprint \
30         python-difflib \
31         python-email \
32         python-compression \
33         python-compile \
34         python-compiler \
35         python-numbers \
36         nfs-utils-client \
37         libshairport \
38         glibc-gconv-utf-32 \
39         xz \
40         tiff \
41         yajl \
42         libxslt \
43         libupnp \
44         libplist \
45         librtmp \
46         libbluray \
47         libnfs \
48 "
49
50 BUILD_PR="r3"
51 NATIVEGLES_PR="20141202_p0"
52
53 BRANCH = "gotham_vuplus"
54 SRCREV = "a4cee0ded4d72572be519ffe8c3aad329113e10a"
55
56 PV = "13.2"
57 PR = "${BUILD_PR}_${NATIVEGLES_PR}_${SRCREV}"
58
59 SRC_URI = "git://code.vuplus.com/git/xbmc.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
60         http://archive.vuplus.com/download/build_support/xbmc-support_${NATIVEGLES_PR}.tar.gz;name=xbmc-support \
61 "
62 S = "${WORKDIR}/git"
63
64 EXTRA_OECONF = " \
65         --disable-rpath \
66         --enable-gles \
67         --enable-libusb \
68         --enable-airplay \
69         --disable-optical-drive \
70         --enable-external-libraries \
71         --disable-ssh \
72         --enable-external_ffmpeg \
73         --disable-x11 \
74         --disable-sdl \
75         --disable-joystick \
76         --disable-alsa \
77         --disable-libcec \
78         --enable-rtmp   \
79         --disable-gnutls \
80         --disable-texturepacker \
81         --with-platform=dvbbox \
82 "
83
84 do_configure_prepend(){
85         cp -av ${WORKDIR}/xbmc-support/gles_init.* ${WORKDIR}/git/xbmc/windowing/egl/
86 }
87
88 do_install_append(){
89         install -d ${D}${bindir}
90         install -m 0755 ${WORKDIR}/xbmc-support/xbmc.helper ${D}${bindir}
91 }
92
93 do_package_qa(){
94 }
95
96 PARALLEL_MAKE = " -j8 "
97
98 FILES_${PN} += "/usr/bin /usr/share /usr/lib"
99
100 SRC_URI[xbmc-support.md5sum] = "9d0c73505484823e3816b5577f28a8a8"
101 SRC_URI[xbmc-support.sha256sum] = "5483e24db81efca03120dbf0ef4cc423d2665ebc4d52149be15d75a0ae9b626d"
102