Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / xbmc / enigma2-plugin-extensions-xbmc.bb
1 SECTION = "base"
2 LICENSE = "CLOSED"
3
4 PKG_DATE="20141219.0_beta"
5
6 PV="1.0"
7 PR="${PKG_DATE}_r0"
8
9 DEPENDS += "enigma2 xbmc"
10 RDEPENDS += "xbmc"
11
12 SRC_URI = "http://archive.vuplus.com/download/build_support/e2xbmc-plugin_${PKG_DATE}.tar.gz"
13
14 S = "${WORKDIR}/plugin"
15
16 PLUGIN_DIR="${D}${libdir}/enigma2/python/Plugins/Extensions/XBMC"
17
18 do_install() {
19         install -d ${PLUGIN_DIR}
20         install -m 0755 ${S}/*.py ${PLUGIN_DIR}
21         install -m 0755 ${S}/button.png ${PLUGIN_DIR}
22 }
23
24 do_package_qa() {
25 }
26
27 FILES_${PN}="/"
28
29 SRC_URI[md5sum] = "31542f3ad42725d2a7ac498be4870e31"
30 SRC_URI[sha256sum] = "f662de7daab96fa690686cbefab597f0cf5e42a7abfc6e414faa1f1c4aff1cdc"
31