7a9c842d1c45037077d458b3e0f0b56fd44931a1
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / gstreamer / gst-plugins-good_0.10.31.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5                     file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \
6                     file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
7
8 DEPENDS += "cdparanoia cairo jpeg libpng zlib libid3tag flac speex libsoup-2.4"
9 DEPENDS += "gst-plugins-base"
10
11 PR = "r5"
12 GIT_PV = ""
13
14 SRCREV = "7768342230450559509e3e593b2ea33e81ea0ca4"
15
16 EXTRA_OECONF = "--enable-orc --disable-esd --disable-aalib --disable-shout2 --disable-libcaca --disable-hal"
17
18 inherit autotools pkgconfig gettext git-project
19
20 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN};branch=0.10"
21
22 SRC_URI += " \
23         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
24         file://0001-accept-substream-syncwords-DTS-HD.patch \
25         file://0004-MatroskaDemux-Set-profile-field-in-cap-for-aac-audio.patch \
26         file://0005-FlvDemux-Set-profile-field-in-cap-for-aac-audio.patch \
27         file://rtsp-check-all-protocols.patch;apply=yes;striplevel=1 \
28 "
29
30 SRC_URI += "file://0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch"
31
32
33 do_common_update() {
34         cd ${S}
35         # Make sure we have common
36         if test ! -f common/gst-autogen.sh;
37         then
38           echo "+ Setting up common submodule"
39           git submodule init
40         fi
41         git submodule update
42
43         # source helper functions
44         if test ! -f common/gst-autogen.sh;
45         then
46           echo There is something wrong with your source tree.
47           echo You are missing common/gst-autogen.sh
48           exit 1
49         fi
50         . common/gst-autogen.sh
51         # install pre-commit hook for doing clean commits
52         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
53         then
54             rm -f .git/hooks/pre-commit
55             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
56         fi
57
58         # GNU gettext automake support doesn't get along with git.
59         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
60         autopoint || touch config.rpath
61         touch -t 200001010000 po/gst-plugins-base-0.10.pot
62 }
63 addtask common_update after do_unpack before do_patch
64
65 do_configure_prepend() {
66         # This m4 file contains nastiness which conflicts with libtool 2.2.2
67         rm ${S}/m4/lib-link.m4 || true
68 }
69
70 require mips-only.inc