gst-plugins-good : remove gtk+ on DEPENDS
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / gstreamer / gst-plugins-good_0.10.31.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5                     file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \
6                     file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
7
8 DEPENDS += "cdparanoia cairo jpeg libpng zlib libid3tag flac speex libsoup-2.4"
9 DEPENDS += "gst-plugins-base"
10
11 PR = "r1"
12 GIT_PV = ""
13
14 SRCREV = "967fc61715fa854dacaa200069437fe57d4d8390"
15
16 EXTRA_OECONF = "--enable-orc --disable-esd --disable-aalib --disable-shout2 --disable-libcaca --disable-hal"
17
18 inherit autotools pkgconfig gettext git-project
19
20 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
21
22 SRC_URI += " \
23         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
24         file://0001-accept-substream-syncwords-DTS-HD.patch \
25 "
26
27 do_common_update() {
28         cd ${S}
29         # Make sure we have common
30         if test ! -f common/gst-autogen.sh;
31         then
32           echo "+ Setting up common submodule"
33           git submodule init
34         fi
35         git submodule update
36
37         # source helper functions
38         if test ! -f common/gst-autogen.sh;
39         then
40           echo There is something wrong with your source tree.
41           echo You are missing common/gst-autogen.sh
42           exit 1
43         fi
44         . common/gst-autogen.sh
45         # install pre-commit hook for doing clean commits
46         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
47         then
48             rm -f .git/hooks/pre-commit
49             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
50         fi
51
52         # GNU gettext automake support doesn't get along with git.
53         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
54         autopoint || touch config.rpath
55         touch -t 200001010000 po/gst-plugins-base-0.10.pot
56 }
57 addtask common_update after do_unpack before do_patch
58
59 do_configure_prepend() {
60         # This m4 file contains nastiness which conflicts with libtool 2.2.2
61         rm ${S}/m4/lib-link.m4 || true
62 }
63
64 require mips-only.inc