Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / gstreamer / gst-plugins-base_0.10.36.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
5                     file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \
6                     file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
7                     file://gst/ffmpegcolorspace/utils.c;beginline=1;endline=20;md5=9c83a200b8e597b26ca29df20fc6ecd0"
8
9 DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxv', '', d)}"
10 DEPENDS += "alsa-lib freetype liboil libogg libvorbis libtheora avahi util-linux tremor orc orc-native"
11 DEPENDS += "gstreamer"
12
13 SRCREV = "bdb33163478fdf95938fbdca7eabad3ea920a277"
14
15 PR = "r2"
16 GIT_PV = ""
17
18 inherit autotools pkgconfig gettext git-project
19
20 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
21
22 SRC_URI += " \
23         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
24         file://disable-vorbis-encoder.patch \
25         file://gst-plugins-base-tremor.patch \
26         file://configure.ac-fix-subparse-plugin.patch \
27 "
28
29 do_common_update() {
30         cd ${S}
31         # Make sure we have common
32         if test ! -f common/gst-autogen.sh;
33         then
34           echo "+ Setting up common submodule"
35           git submodule init
36         fi
37         git submodule update
38
39         # source helper functions
40         if test ! -f common/gst-autogen.sh;
41         then
42           echo There is something wrong with your source tree.
43           echo You are missing common/gst-autogen.sh
44           exit 1
45         fi
46         . common/gst-autogen.sh
47         # install pre-commit hook for doing clean commits
48         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
49         then
50             rm -f .git/hooks/pre-commit
51             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
52         fi
53
54         # GNU gettext automake support doesn't get along with git.
55         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
56         autopoint || touch config.rpath
57         touch -t 200001010000 po/gst-plugins-base-0.10.pot
58 }
59 addtask common_update after do_unpack before do_patch
60
61 do_configure_prepend() {
62         # This m4 file contains nastiness which conflicts with libtool 2.2.2
63         rm ${S}/m4/lib-link.m4 || true
64 }
65
66 require mips-only.inc