gstreamer plugins updated.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-multimedia / gstreamer / gst-plugins-bad_0.10.23.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+ "
4 LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
5                     file://gst/tta/filters.h;beginline=12;endline=29;md5=629b0c7a665d155a6677778f4460ec06 \
6                     file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
7                     file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c"
8
9 DEPENDS += "libmusicbrainz tremor curl libmms librtmp libmms"
10 DEPENDS += "gst-plugins-base"
11 CONFLICTS = "librsvg"
12
13 PR = "r4"
14 GIT_PV = ""
15
16 SRCREV = "cef47d85294a0dca38631f938b81a3f0dd6891bd"
17
18 EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio --disable-directfb \
19                  --disable-vdpau --disable-apexsink --enable-orc --disable-mpeg2enc --disable-mplex --disable-rsvg --disable-uvch264"
20
21 ARM_INSTRUCTION_SET = "arm"
22
23 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
24
25 SRC_URI += " \
26         file://0003-mpegpsdemux_speedup.diff.patch \
27         file://0004-mpegdemux-compile-fixes.patch \
28         file://0005-hlsdemux-locking-fixes.patch \
29         file://0006-hlsdemux-backport.patch \
30         file://0007-revert-rtmp-change.patch \
31         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
32 "
33
34 inherit autotools pkgconfig gettext git-project
35
36 do_common_update() {
37         cd ${S}
38         # Make sure we have common
39         if test ! -f common/gst-autogen.sh;
40         then
41           echo "+ Setting up common submodule"
42           git submodule init
43         fi
44         git submodule update
45
46         # source helper functions
47         if test ! -f common/gst-autogen.sh;
48         then
49           echo There is something wrong with your source tree.
50           echo You are missing common/gst-autogen.sh
51           exit 1
52         fi
53         . common/gst-autogen.sh
54         # install pre-commit hook for doing clean commits
55         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
56         then
57             rm -f .git/hooks/pre-commit
58             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
59         fi
60
61         # GNU gettext automake support doesn't get along with git.
62         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
63         autopoint || touch config.rpath
64         touch -t 200001010000 po/gst-plugins-base-0.10.pot
65 }
66 addtask common_update after do_unpack before do_patch
67
68 do_configure_prepend() {
69         # This m4 file contains nastiness which conflicts with libtool 2.2.2
70         rm ${S}/m4/lib-link.m4 || true
71 }
72
73 require mips-only.inc