a6948ab89d89c61eaaf3ff45144ee6e4ec63e63c
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-graphics / libvugles2 / libvugles2_0.1.0.bb
1 DESCRIPTION = "shared library for E2 animation"
2 SECTION = "libs"
3 LICENSE = "CLOSED"
4 require conf/license/license-close.inc
5
6 RDEPENDS_${PN} = "libgles"
7
8 SRCDATE = "20150109"
9 SRCDATE_PR = "r1"
10 PR = "${SRCDATE}.${SRCDATE_PR}"
11
12 SRC_URI = "http://archive.vuplus.com/download/build_support/vuplus/${PN}-${PV}-${PR}.tar.gz"
13
14 INHIBIT_PACKAGE_STRIP = "1"
15 S = "${WORKDIR}/${PN}-${PV}"
16
17 inherit pkgconfig
18
19 do_install() {
20         install -d ${D}${includedir}
21         cp -a ${S}/include/* ${D}${includedir}/
22         install -d ${D}${libdir}
23         cp -a ${S}/lib/*.so ${D}${libdir}/
24         install -d ${D}${libdir}/pkgconfig
25         cp -a ${S}/lib/pkgconfig/*.pc ${D}${libdir}/pkgconfig/
26 }
27
28 do_package_qa() {
29 }
30
31 PACKAGE_ARCH := "${MACHINE_ARCH}"
32
33 PACKAGES = "${PN}"
34 FILES_${PN} = "/usr/include /usr/lib"
35
36 SRC_URI[md5sum] = "6aa14c822d9975334d964d385a6b5926"
37 SRC_URI[sha256sum] = "1e321ca68e14401d4115fb5ac7934c025b0a2b266d1556905f5ef324968921e3"