Merge remote-tracking branch 'oe_21/master' into vuplus-3.0-next
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-graphics / libgles / libgles.bb
1 SECTION = "base"
2 LICENSE = "CLOSED"
3
4 PV="15.1"
5 PR="${SRCDATE}.${SRCDATE_PR}"
6
7 SRC_URI = "http://archive.vuplus.com/download/build_support/vuplus/libgles-${MACHINE}-${PV}-${PR}.tar.gz"
8
9 S = "${WORKDIR}/libgles-${MACHINE}"
10
11 do_install() {
12         install -d ${D}${libdir}
13         install -m 0755 ${S}/lib/*.so ${D}${libdir}
14         ln -s libv3ddriver.so ${D}${libdir}/libEGL.so
15         ln -s libv3ddriver.so ${D}${libdir}/libGLESv2.so
16
17         install -d ${D}${includedir}
18         cp -a ${S}/include/* ${D}${includedir}/
19 }
20
21 do_package_qa() {
22 }
23
24 PACKAGE_ARCH := "${MACHINE_ARCH}"
25 PACKAGES = "${PN}"
26 FILES_${PN}="/usr/lib /usr/include"
27