Merge remote-tracking branch 'OE-2.1/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-graphics / freetype / freetype_2.4.12.bb
1 SUMMARY = "Freetype font rendering library"
2 DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3 highly customizable, and portable while capable of producing high-quality output (glyph \
4 images). It can be used in graphics libraries, display servers, font conversion tools, text \
5 image generation tools, and many other products as well."
6 HOMEPAGE = "http://www.freetype.org/"
7 BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9 LICENSE = "FreeType | GPLv2+"
10 LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=c017ff17fc6f0794adf93db5559ccd56 \
11                     file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12                     file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14 SECTION = "libs"
15
16 PR = "r0"
17
18 SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
19 "
20
21 SRC_URI[md5sum] = "3463102764315eb86c0d3c2e1f3ffb7d"
22 SRC_URI[sha256sum] = "a78a17486689ab6852a9e1a759b179827ac9dfd7e2f237ddf169c73398c85381"
23
24 S = "${WORKDIR}/freetype-${PV}"
25
26 inherit autotools-brokensep pkgconfig binconfig
27
28 LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
29 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
30 EXTRA_OEMAKE_class-native = ""
31 EXTRA_OECONF = "--without-zlib --without-bzip2 CC_BUILD='${BUILD_CC}'"
32
33 do_configure() {
34         cd builds/unix
35         libtoolize --force --copy
36         aclocal -I .
37         gnu-configize --force
38         autoconf
39         cd ${S}
40         oe_runconf
41 }
42
43 do_configure_class-native() {
44         (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
45         oe_runconf
46 }
47
48 do_compile_prepend() {
49         ${BUILD_CC} -o objs/apinames src/tools/apinames.c
50 }
51
52 BBCLASSEXTEND = "native"
53