2b5dde500afe1671436f6339e25385057a22cd99
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-extended / libvupl-examples / libvupl-example-cube_0.2.0.bb
1 DESCRIPTION = "Cube Demo example for libvupl"
2 SECTION = "devel"
3 HOMEPAGE = "https://code.google.com/archive/p/opengles-book-samples/"
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=7c01ce978e205f99897d26c061b2c09a"
6
7 PR = "r1"
8
9 DEPENDS = "libvupl libgles"
10 RDEPENDS_${PN} = "libvupl libgles"
11
12 SRC_URI = "http://archive.vuplus.com/download/build_support/${PN}-${PV}.${PR}.tar.gz"
13
14 S = "${WORKDIR}/${PN}-${PV}"
15
16 EXTRA_OECMAKE += "-DVUPLUS=1"
17
18 inherit cmake
19
20 do_install() {
21         install -d ${D}/usr/bin
22         install -m 0755 ${WORKDIR}/build/Simple_VertexShader/Simple_VertexShader ${D}/usr/bin/cube
23 }
24
25 SRC_URI[md5sum] = "fe812abfc9c52ed26c4aa7192f94fe03"
26 SRC_URI[sha256sum] = "0cc58ec3d6d0d1be358e805268fa29704dde6fceeace8bc60d001bb63dac26ee"