add recipes-wlan, e2openplugins
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-enigma2 / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=c9e255efa454e0155c1fd758df7dcaf3"
5 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
6         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
7         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
8         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi \
9         hostap-daemon bridge-utils \
10 "
11
12 # DEPENDS += "wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data djmount minidlna"
13
14 RDEPENDS_GST= "gst-plugins-base-decodebin gst-plugins-base-decodebin2 gst-plugins-base-app gst-plugins-bad-fragmented \
15                 gst-plugins-good-id3demux gst-plugins-ugly-mad gst-plugins-base-ogg gst-plugins-base-playbin \
16                 gst-plugins-base-typefindfunctions gst-plugins-base-audioconvert gst-plugins-base-audioresample \
17                 gst-plugins-good-wavparse gst-plugins-ugly-mpegstream \
18                 gst-plugins-good-flac gst-plugin-dvbmediasink gst-plugins-bad-mpegdemux gst-plugins-ugly-dvdsub \
19                 gst-plugins-good-souphttpsrc gst-plugins-ugly-mpegaudioparse gst-plugins-base-subparse \
20                 gst-plugins-good-apetag gst-plugins-good-icydemux gst-plugins-good-autodetect gst-plugins-good-flv \
21 "
22
23 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
24                 python-xml python-fcntl python-stringold python-pickle python-netclient \
25                 glibc-gconv-iso8859-15 ethtool \
26                 ${RDEPENDS_GST} \
27 "
28
29 GST_RTSP_RDEPENDS = "gst-plugins-good-udp gst-plugins-good-rtsp gst-plugins-good-rtp gst-plugins-good-rtpmanager"
30 GST_ALSA_RDEPENDS = "gst-plugins-base-alsa alsa-conf"
31 GST_MISC_RDEPENDS = "gst-plugins-good-matroska gst-plugins-good-isomp4 gst-plugins-base-vorbis gst-plugins-good-audioparsers"
32 GST_DVD_RDEPENDS = "gst-plugins-bad-cdxaparse gst-plugins-ugly-cdio gst-plugins-bad-vcdsrc"
33 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
34
35 RDEPENDS_append_vuplus = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugins-good-avi"
36
37 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
38 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
39 #DEPENDS += "enigma2-plugins"
40 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
41
42 SUMMARY_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
43 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
44 SUMMARY_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
45 SUMMARY_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
46 SUMMARY_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
47 SUMMARY_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
48 SUMMARY_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
49 SUMMARY_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
50 SUMMARY_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
51 SUMMARY_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
52 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
53 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "python-twisted-web"
54 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "python-twisted-web"
55 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
56 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
57 SUMMARY_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
58 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "python-twisted-mail python-twisted-names python-compression python-mime python-email"
59 SUMMARY_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
60 SUMMARY_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
61 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
62 SUMMARY_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
63 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
64 SUMMARY_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
65 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
66 SUMMARY_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
67 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
68 SUMMARY_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
69 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "python-twisted-mail python-twisted-names python-compression python-mime python-email"
70 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
71 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
72 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugins-bad-rtmp "
73 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount fuse-utils libfuse2 libupnp3 kernel-module-fuse "
74 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat52 libavutil50 libavcodec52 libgsm1 libmp3lame0 libschroedinger-1.0-0 libtheora0 liboil"
75
76 PN = "enigma2"
77 PR = "r38"
78
79 SRCDATE = "20110922"
80 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
81 #SRCDATE is NOT used by git to checkout a specific revision
82 #but we need it to build a ipk package version
83 #when you like to checkout a specific revision of e2 you need
84 #have to specify a commit id or a tag name in SRCREV
85
86 # if you want experimental use
87 ####################################################
88 BRANCH = "experimental"
89 PV = "experimental-git${SRCDATE}"
90 #SRCREV = ""
91 ####################################################
92
93 # if you want a 2.7-based release, use
94 ####################################################
95 #BRANCH="2.7"
96 #PV = "2.7git${SRCDATE}"
97 # if you want 2.7.0 use
98 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
99 ####################################################
100
101 # if you want a vuplus release, use
102 ####################################################
103 #BRANCH_vuplus = "vuplus"
104 #PV_vuplus = "2.8git${SRCDATE}"
105 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
106 ####################################################
107
108 #if you want a vuplus experimental, use
109 ####################################################
110 BRANCH_vuplus = "vuplus_experimental"
111 PV_vuplus = "experimental-git${SRCDATE}"
112 SRCREV_vuplus = ""
113 ####################################################
114
115 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
116
117 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
118            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
119            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
120            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
121            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
122            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
123            file://enigma2_vuplus_addlibpythondeps.patch;patch=1;pnum=1 \
124            file://MyriadPro-Regular.otf \
125            file://MyriadPro-Semibold.otf \
126            file://MyriadPro-SemiboldIt.otf \
127            file://750S \
128            file://Vu_HD \
129            file://number_key \
130            "
131
132 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
133
134 def change_po():
135         import os
136         try:
137                 os.system("find ./ -name \"*.po\" > ./po_list")
138                 os.system("find ./ -name \"*.pot\" >> ./po_list")
139                 po_list = []
140                 po_list = open('po_list','r+').readlines()
141                 for x in po_list:
142                         changeword(x)
143                 os.system('rm po_list')
144         except:
145                 print 'word patch error '
146                 return
147
148 def changeword(file):
149         fn = file[:-1]
150         fnn = file[:-1]+'_n'
151         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
152         os.system(cmd)
153         cmd1 = "mv "+fnn+" "+fn
154         os.system(cmd1)
155
156 do_unpack_append(){
157         change_po()
158 }
159
160 S = "${WORKDIR}/git"
161
162 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
163 FILES_${PN}-meta = "${datadir}/meta"
164 PACKAGES += "${PN}-meta"
165 PACKAGE_ARCH = "${MACHINE_ARCH}"
166
167 inherit autotools pkgconfig
168
169
170 do_compile_prepend_vuplus() {
171         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
172         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
173         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
174         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
175         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
176         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
177         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
178         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
179         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
180         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
181         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
182         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
183         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
184         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
185         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
186 }
187
188 EXTRA_OECONF = " \
189         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
190         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
191         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
192         ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
193         BUILD_SYS=${BUILD_SYS} \
194         HOST_SYS=${HOST_SYS} \
195         STAGING_INCDIR=${STAGING_INCDIR} \
196         STAGING_LIBDIR=${STAGING_LIBDIR} \
197 "
198
199 python populate_packages_prepend() {
200         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
201         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/[a-zA-Z0-9_]+.*$', 'enigma2-plugin-%s', '%s', recursive=True, match_path=True, prepend=True)
202         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/.*\.la$', 'enigma2-plugin-%s-dev', '%s (development)', recursive=True, match_path=True, prepend=True)
203         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/.*\.a$', 'enigma2-plugin-%s-staticdev', '%s (static development)', recursive=True, match_path=True, prepend=True)
204         do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/(.*/)?\.debug/.*$', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
205 }
206
207 RCONFLICTS_${PN} = "dreambox-keymaps"
208 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
209
210 # workaround for opkg <= 0.1.7+svnr455-r19.1
211 #pkg_preinst_${PN} () {
212 #       if [ "x$D" != "x" ]; then
213 #               exit 1
214 #       fi
215 #       if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
216 #               cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
217 #       fi
218 #}
219 #pkg_postinst_${PN} () {
220 #       if [ "x$D" != "x" ]; then
221 #               exit 1
222 #       fi
223 #       if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
224 #               mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
225 #       fi
226 #}