task-vuplus-enigma2
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-enigma2 / dreambox-dvbincludes / dreambox-dvbincludes_1.1.bb
1 SUMMARY = "dbox2/dreambox compatible header files"
2 LICENSE = "GPLv2+"
3 LIC_FILES_CHKSUM = "file://dbox/avs_core.h;beginline=1;endline=21;md5=b2ab401756a0768647ae13acb2e325ab"
4 PR = "r1"
5
6 SRC_URI = "http://sources.dreamboxupdate.com/snapshots/include2.tar.gz"
7 SRC_URI[md5sum] = "9d236095a88d7ce9f3bf0503ee5237d6"
8 SRC_URI[sha256sum] = "739bc35bccdb1e4c6e14b77ab86808354eb6fd75434d3bd6236f3b3346805e02"
9
10 S = "${WORKDIR}/include"
11
12 # avs_core.h and saa7126_core.h are obsolete, but
13 # libtuxtxt currently doesn't compile without them.
14 INPUT_FILES = " \
15         dbox/fp.h \
16         dbox/lcd-ks0713.h \
17         dbox/avs_core.h \
18         dbox/saa7126_core.h \
19 "
20
21 do_install() {
22         install -d ${D}${includedir}/dbox
23         for f in ${INPUT_FILES}; do
24                 install -m 0644 $f ${D}${includedir}/$f
25         done
26 }