revert OE-core commit "python: remove the default optimization" (commit : 165ed464bbb...
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-devtools / python / python-coherence_git.bb
1 SUMMARY = "Python UPnP framework"
2 HOMEPAGE = "http://coherence.beebits.net/"
3 SECTION = "devel/python"
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://LICENCE;md5=3f7c147addd67ce1d53239c68a6b7022"
6 DEPENDS = "libxml2"
7 SRCREV = "d4d3be1305bb9cb24845ac7dd9e8135a7b7f6d67"
8 PV = "0.6.7"
9 PR = "r5"
10
11 SRC_URI = "git://github.com/sreichholf/coherence.git;protocol=git"
12
13 S = "${WORKDIR}/git/Coherence"
14
15 inherit setuptools
16
17 do_configure_prepend() {
18         sed -e 's,^from coherence import __version__$,__version__ = "${PV}",' -i setup.py
19 }
20 do_install_append() {
21         rm ${D}${bindir}/applet-coherence
22         rm -r ${D}${PYTHON_SITEPACKAGES_DIR}/Coherence-${PV}-*.egg-info
23         rm -r ${D}${PYTHON_SITEPACKAGES_DIR}/coherence/test
24         rm -r ${D}${PYTHON_SITEPACKAGES_DIR}/misc/Desktop-Applet
25 }
26
27 RDEPENDS_${PN} = "python-xmlrpc python-twisted-web"
28
29 PACKAGES =+ "${PN}-bin"
30
31 RDEPENDS_${PN}-bin = "${PN} python-zopeinterface"
32
33 FILES_${PN}-bin = "${bindir} ${PYTHON_SITEPACKAGES_DIR}/misc/*.py"