[dvbapp] increase PR.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-devtools / bison / bison_2.7.1.bb
1 SUMMARY = "GNU Project parser generator (yacc replacement)"
2 DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3 an LALR(1) or GLR parser for that grammar.  Bison is upward compatible with Yacc: all properly-written Yacc \
4 grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5 little trouble."
6 HOMEPAGE = "http://www.gnu.org/software/bison/"
7 LICENSE = "GPLv3"
8 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9 SECTION = "devel"
10 DEPENDS = "bison-native flex-native"
11
12 BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13                 file://m4.patch \
14                 file://dont-depend-on-help2man.patch \
15                "
16
17 # No point in hardcoding path to m4, just use PATH
18 EXTRA_OECONF += "M4=m4"
19
20 SRC_URI = "${BASE_SRC_URI} \
21            file://fix_cross_manpage_building.patch \
22           "
23
24 SRC_URI[md5sum] = "7be02eb973eccf388f1ae750fc09eed0"
25 SRC_URI[sha256sum] = "b409adcbf245baadb68d2f66accf6fdca5e282cafec1b865f4b5e963ba8ea7fb"
26
27 LDFLAGS_prepend_libc-uclibc = " -lrt "
28 DEPENDS_class-native = "gettext-minimal-native"
29 SRC_URI_class-native = "${BASE_SRC_URI}"
30
31 inherit autotools gettext texinfo
32 acpaths = "-I ${S}/m4"
33
34 do_install_append_class-native() {
35         create_wrapper ${D}/${bindir}/bison \
36                 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
37 }
38 BBCLASSEXTEND = "native nativesdk"