Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-core / initscripts / initscripts_1.0.bbappend
1 PR .= "-vuplus3"
2
3 BOOTUP = "bootup_3.1" 
4
5 SRC_URI_append = " \
6         file://turnoff_power \
7         file://hotplug_br \
8         file://make_mac_sector \
9         file://${BOOTUP} \
10 "
11
12 do_install_append() {
13         rm ${D}${sysconfdir}/*.d/*save-rtc.sh
14
15         install -d ${D}/usr/bin 
16         install -m 0755 ${WORKDIR}/turnoff_power     ${D}/usr/bin
17         install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
18         install -m 0755 ${WORKDIR}/make_mac_sector   ${D}/usr/bin
19         install -m 0755 ${WORKDIR}/${BOOTUP}         ${D}${sysconfdir}/init.d/bootup
20         ln      -sf     ../init.d/bootup             ${D}${sysconfdir}/rcS.d/S05bootup
21 }
22
23 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
24
25 PACKAGE_ARCH = "${MACHINE_ARCH}"