Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-core / initscripts / initscripts_1.0.bbappend
1 PR .= "-vuplus11"
2
3 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
4
5 SRC_URI_append = " \
6         file://turnoff_power \
7         file://hotplug_br \
8         file://make_mac_sector \
9 "
10
11 do_configure_prepend() {
12         sed -i 's/tty0/ttyS0/' ${WORKDIR}/banner.sh
13 }
14
15 do_install_append() {
16         rm ${D}${sysconfdir}/*.d/*save-rtc.sh
17
18         install -d ${D}/usr/bin 
19         install -m 0755 ${WORKDIR}/turnoff_power     ${D}/usr/bin
20         install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
21         install -m 0755 ${WORKDIR}/make_mac_sector   ${D}/usr/bin
22
23         # rename umountnfs script because it should run before network is disabled
24         mv ${D}${sysconfdir}/rc0.d/S31umountnfs.sh ${D}${sysconfdir}/rc0.d/K31umountnfs.sh || /bin/true
25         mv ${D}${sysconfdir}/rc6.d/S31umountnfs.sh ${D}${sysconfdir}/rc6.d/K31umountnfs.sh || /bin/true
26 }
27
28 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
29
30 PACKAGE_ARCH = "${MACHINE_ARCH}"