Solo4K Support.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-core / initscripts / initscripts_1.0.bbappend
1 PR .= "-vuplus13"
2
3 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
4
5 SRC_URI_append = " \
6         file://turnoff_power \
7         file://make_mac_sector \
8 "
9
10 SRC_URI_append_mipsel = " \
11         file://hotplug_br \
12 "
13
14 do_configure_prepend() {
15         sed -i 's/tty0/ttyS0/' ${WORKDIR}/banner.sh
16 }
17
18 do_install_append() {
19         rm ${D}${sysconfdir}/*.d/*save-rtc.sh
20
21         install -d ${D}/usr/bin 
22         install -m 0755 ${WORKDIR}/turnoff_power     ${D}/usr/bin
23         install -m 0755 ${WORKDIR}/make_mac_sector   ${D}/usr/bin
24
25         # rename umountnfs script because it should run before network is disabled
26         mv ${D}${sysconfdir}/rc0.d/S31umountnfs.sh ${D}${sysconfdir}/rc0.d/K31umountnfs.sh || /bin/true
27         mv ${D}${sysconfdir}/rc6.d/S31umountnfs.sh ${D}${sysconfdir}/rc6.d/K31umountnfs.sh || /bin/true
28 }
29
30 do_install_append_mipsel() {
31         install -m 0755 ${WORKDIR}/hotplug_br        ${D}/usr/bin
32 }
33
34 FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
35
36 PACKAGE_ARCH = "${MACHINE_ARCH}"